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What is Sandcat?
Sandcat is a remote web application security assessment scanner. It allows you to scan for the most common web
application flaws from a hacker's perspective. Sandcat will remotely inject data in the web applications and analyze the
application response in order to determine if the application code is vulnerable to specific attacks (such as SQL Injection,
XSS, and many other web application vulnerability flaws).

Which operating systems and applications are supported for scanning?
Sandcat modules are built with the flexibility to cover multiple web server platforms:

   1. Any web server platform (via remote scanning). Sandcat scans all types of web servers, such as Unix, Linux or NT.
   2. Devices such as routers and firewalls that run web sites.
   3. Tests intrusion detection systems.
   4. An assessment tool designed specifically for Apache and PHP platforms is also available. 

How many new vulnerabilities added last year (2007)?
More than 3000 new server checks. A complete list is available online at 
http://www.syhunt.com/index.php?section=resources.updates

Does Sandcat includes checks for vulnerabilities discovered by Syhunt?
Yes, recently we've discovered multiple vulnerabilities in a file sharing focused web server. The vendor was contacted and
these vulnerabilities were fixed. We then published an exploit demonstration tool and three advisories in our website, and
immediately included checks in Sandcat. This is our standard procedure when we discover vulnerabilities.

How often does Syhunt provide updates and how are they distributed?
Immediate to monthly, depending on the severity of new discovered vulnerabilities and the range of affected systems. We
do provide automatic (automatic update feature) or manual updates (manual downloading).
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Scanner Checks

Sandcat scans for the vulnerabilities listed in the OWASP's Top Ten Most Critical Web Application Security
Vulnerabilities and the PHP Top 5 Vulnerabilities documents. It includes a fault-injection test module for that purpose
(scanning for vulnerabilities in custom-built web applications). The tool's database includes over 260 web application
security checks in over 38 categories of web attacks. We have been adding new attack variants on a regular basis.
Remote command execution, XSS (cross-site scripting), SQL injection, PHP configuration and filesystem attacks are
some of the most known types of vulnerabilities tested by Sandcat.

A complete list of checks performed by Sandcat is available at http://www.syhunt.com/index.php?section=sandcat.checks
.

A list of CVEs and OSVDB entries researched is also available at http://www.syhunt.com/index.php?section=sandcat.cve

We've been focusing our attention in databases, projects and standards from some of the organizations listed at:
http://www.syhunt.com/index.php?section=resources.links

Compliance

An overview document about the Sandcat Compliance features is available at 
http://www.syhunt.com/docs1/Sandcat_Compliance.pdf.

A complete list of the compliance checks is available at http://www.syhunt.com/index.php?section=sandcat.checks.

MX Injection Checks

We're proud to say that Sandcat is the first web application scanner to perform MX Injection checks. More than 20 variants
of MX Injection attacks are tested. For more information about MX Injection vulnerabilities, visit:
http://www.webappsec.org/projects/articles/121106.shtml
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Installation
Download Information

Sandcat is available for download at: http://www.syhunt.com/index.php?section=sandcat.download

Sandcat Pro is available for download at: http://www.syhunt.com/index.php?section=members.home. Please note that
this version is only available for registered users.

System Requirements

Sandcat™

   1. 20 MB of memory
   2. 100 MB of free disk space
   3. Any Win32 platform (Windows 95, 98, ME, NT, 2000, 2003, XP or Vista)
   4. As a user of Windows 2000, 2003, XP or Vista you may need to be logged in with full administration rights
   5. Python (optional for running Sandcat Extensions written in Python language)

Sandcat™ Professional

   1. 20 MB of memory
   2. 100 MB of free disk space
   3. Internet connection (optional for remote scanning or performing automatic updates)
   4. Any Win32 platform (Windows 95, 98, ME, NT, 2000, 2003, XP or Vista)
   5. As a user of Windows 2000, 2003, XP or Vista you may need to be logged in with full administration rights
   6. Python (optional for running Sandcat Extensions written in Python language)

Wine

Sandcat 3.4 or later: Sandcat runs under WINE for Linux though it is not supported. The SmartUpdate feature specifically
will not work under WINE. Numerous changes have been made in Sandcat 3.5 and it doesn't run perfectly under WINE
unless when executed as individual modules. We will address this compatibility issue in the next releases

Personal Firewalls

If you use a personal firewall, you'll just have to let the firewall know that Sandcat is authorized to make connections to the
Internet. However, some software firewalls do not handle high loads very well. It is not recommended to run both a personal
firewall and Sandcat on the same machine.

Liability Disclaimer

This software should be used only by system administrators (or other people in charge). It should not be used to scan web
sites outside of your direct control.

The entire risk arising out of the use or performance of such products and documentation remains with you. In no event
shall Syhunt or its suppliers be liable for any damages whatsoever (including, without limitation, damages for loss of
business profits, business interruption, loss of business information, or other pecuniary loss) arising out of the use of or
inability to use the products or documentation, even if Syhunt has been advised of the possibility of such damages.
Because some states/ jurisdictions do not allow the exclusion or limitation of liability for consequential or incidental
damages, the above limitation may not apply to you.
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Syhunt EULA

NOTICE -- READ ALL OF THE TERMS AND CONDITIONS OF THIS END USER LICENSE AGREEMENT BEFORE
DOWNLOADING, COPYING, INSTALLING OR USING THE SOFTWARE, CONTENT, DATA OR DOCUMENTATION
(EACH AS DEFINED BELOW).

INSTALLING AND/OR USING THE SOFTWARE, SERVICE, CONTENT, DATA AND DOCUMENTATION (COLLECTIVELY,
THE "PRODUCT") INDICATES YOUR ACCEPTANCE OF THESE TERMS AND CONDITIONS. IF YOU DO NOT ACCEPT
THESE TERMS AND CONDITIONS, YOU MUST DELETE ANY SOFTWARE, CONTENT AND DATA FROM YOUR
HARDWARE. PLEASE NOTE THAT YOU MAY NOT USE, COPY, MODIFY OR TRANSFER THE PRODUCT, OR ANY
COPY OR PORTION THEREOF, EXCEPT AS EXPRESSLY PROVIDED IN THIS LICENSE AGREEMENT.

IMPORTANT -- READ CAREFULLY: By clicking on the "Yes" or other appropriate assent button to make and use copies
of the Syhunt Vulnerability Assessment Software (the "Software"), access the Syhunt Vulnerability Assessment service
via any computer (the "Service") and to use the vulnerability data (the "Data") and other content accessed therewith (the
"Content"), you ("Licensee") agree to be and are hereby bound by the terms and conditions of this License Agreement
(this "Agreement"). If applicable, Licensee must also agree to certain terms and conditions relating to Licensee's
subscription to the Software, Service, Content and Data, as may be required by third-parties processing any fees on behalf
of Syhunt (the "Third Party Subscription Terms"). If Licensee does not agree to the terms and conditions of this Agreement
(and the Third Party Subscription Terms, if applicable), Licensee should not download, copy, install or use the Product and
must promptly destroy any and all copies of the Software, Service, Content, Data and any accompanying documentation
("Documentation") made by Licensee.

I. SYHUNT'S SUBSCRIPTION TERMS. For purposes of this Agreement, the "Syhunt Site" shall mean the web site
currently located at www.syhunt.com.

A. For Trial Subscriptions. Syhunt does not charge a subscription fee for Licensee's trial use of the Product. Licensee
shall however be subject to the terms and conditions of this Agreement and Licensee's use of the Product during the
applicable trial period may be terminated by Syhunt in the event Licensee breaches any term of this Agreement.

At the end of the applicable trial period, Licensee shall have the option of subscribing to the Syhunt Vulnerability
Assessment Professional Product by visiting www.shareit.com or the Syhunt Site and providing relevant payment
information. In the event Licensee does not purchase a subscription at the end of the applicable trial period, either (a) the
Syhunt Vulnerability Assessment Professional Product will be disabled and Licensee will instead be provided with the
Syhunt Vulnerability Assessment Free Product, which Licensee will have the right to use subject to the terms below, if
Licensee had a trial subscription of the Product, or (b) the Product will be disabled in its entirety if Licensee had a trial
subscription of the Product.

B. For Syhunt Free Subscriptions. Syhunt does not charge a subscription fee for Licensee's use of the Syhunt
Vulnerability Assessment Free Product, which offers limited content and functionality. Licensee's use of Syhunt Free shall
subject to the terms and conditions of this Agreement.

C. For Annual Syhunt Vulnerability Assessment Professional Subscriptions. To subscribe to the Syhunt Vulnerability
Assessment Professional Product from the website currently located at www.shareit.com (the "Share-it Site"), Licensee
agrees to pay Syhunt's payment processing partner, Share-it, Inc. ("Share-it"), the applicable annual subscription fee listed
on the Share-it Site, any applicable taxes and any other charges incurred on Licensee's user name and password.
Subscription fees will be billed by Share-it to Licensee at the beginning of Licensee's subscription. Syhunt reserves the
right to increase its subscription fee or institute new fees at any time, upon reasonable notice posted in advance on the
Share-it Site. Licensee shall not be charged retroactively for any such increased or new fees but shall be billed the
applicable increased or new fee upon renewal, if any.

1. Money Back Guarantee. All fees are non-refundable except as otherwise set forth in this Agreement.

2. Renewal. If Licensee desires to renew Licensee's subscription to the Syhunt Vulnerability Assessment Professional
Product, Licensee must visit either www.shareit.com or the Syhunt Site and provide relevant payment information. Share-it
will not automatically charge Licensee for renewals. Syhunt will use reasonable efforts to send a reminder prior to the end
of Licensee's current subscription period to the e-mail address Licensee provided in connection with Licensee's registration
on the Share-it Site.

D. Other Charges. In addition to the subscription fees and obligations set forth in Sections A through C above, Licensee is
responsible for all charges associated with connecting to the Syhunt Site, including all telephone line access, telephone
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and computer equipment and any related service fees.

II. GRANT OF LICENSE.

Syhunt Informática, Ltda. ("Syhunt") hereby grants to Licensee a non-exclusive license to use the Software, Service,
Content, Data and Documentation subject to the following terms:

Licensee may: (a) install the Software on one computer and use the Software, Content and Data for personal,
non-commercial purposes only; (b) access the Service via one computer; (c) view the Content and the Data in connection
with the Software and/or Service on the screen of such computer; (d) save the Content and the Data on such computer,
provided that Licensee does not remove any copyright notices that appear in connection therewith and does not modify the
Content or the Data in any way; and (e) make one copy of the Software, Content and Data for back-up, archival purposes,
provided such copy contains all of the original proprietary notices provided with or otherwise relating to such Software,
Content and Data. Notwithstanding anything in this paragraph, Licensee may transfer the Software from one computer to
another computer in connection with Licensee's use of the Product, provided that (i) Licensee deletes all copies of the
Software from the first device, and (ii) Licensee may use the Product on only one computer at a time.

Licensee may not use, or permit other individuals or entities to use, the Software, Service, Content, Data or
Documentation except under the terms expressly listed above. Without limiting the foregoing sentence, Licensee shall not,
and shall not permit any other individual or entity to: (a) use the Software, Service, or Data for service bureau, time-sharing
or other similar purposes; (b) use the Product following expiration or termination of the applicable subscription period; (c)
modify, translate, reverse engineer, decompile, disassemble (except to the extent that this restriction is expressly
prohibited by law) or create derivative works based upon the Software, Service, Content, Data or Documentation; (d) copy
the Software, Service, Content, Data or Documentation (except as permitted above); (e) rent, lease, sell, offer to sell,
distribute, or otherwise transfer rights to the Software, Service, Content, Data or Documentation; and (f) remove any
proprietary notices or labels on or relating to the Software, Service, Content, Data or Documentation. Licensee
acknowledges that Syhunt has the right to remove listings, restrict access, terminate and otherwise modify the services
provided by Syhunt from the Syhunt Site for any reason, including but not limited to a breach of any of the Terms of
Service agreement set forth on the Syhunt Site (the "Terms of Service Agreement"), or the Third Party Subscription Terms
if applicable.

III. ENHANCEMENTS AND UPDATES.

This license does not grant Licensee any right to any enhancement or update of the Software, Service, Content, Data and
Documentation.

IV. TITLE.

All right, title and interest in and to the Software, Service, Content, Data and Documentation (including without limitation all
intellectual property rights) shall remain in Syhunt and/or its suppliers and licensors. Without limiting the foregoing: (a) the
Software, Service, Content, Data and Documentation are protected by copyright laws and international copyright treaties;
and (b) the Content (including the content contained in the Software media demonstration files) and Data, and all rights
thereto, are the property of the applicable content owner and are protected by applicable copyright or other law. This
license gives Licensee no rights to such Content or Data.

The following copyright notices apply to, and shall not be removed from, the Software and the Documentation and certain
Content available in connection therewith:

©2005 Syhunt Informatica Ltda. All rights reserved.

V. DISCLAIMERS.

THE SOFTWARE, SERVICE, CONTENT, DATA AND DOCUMENTATION ARE PROVIDED "AS IS" AND WITHOUT
WARRANTY OF ANY KIND. TO THE MAXIMUM EXTENT PERMITTED BY APPLICABLE LAW, SYHUNT AND ITS
LICENSORS AND SUPPLIERS FURTHER DISCLAIM ALL WARRANTIES OF ANY KIND (WHETHER EXPRESS OR
IMPLIED, ARISING BY LAW OR OTHERWISE), INCLUDING WITHOUT LIMITATION ANY WARRANTIES OF
PERFORMANCE, MERCHANTABILITY AND NONINFRINGEMENT. SYHUNT AND ITS LICENSORS AND SUPPLIERS
ALSO DISCLAIM ALL WARRANTIES OF QUALITY, ACCURACY, COMPLETENESS, EFFECTIVENESS, RELIABILITY,
FITNESS FOR A PARTICULAR PURPOSE, USEFULNESS, USE OR RESULTS TO BE OBTAINED FROM THE
CONTENT OR THE DATA, OR THAT THE CONTENT OR THE DATA WILL BE ERROR-FREE. TO THE EXTENT
ALLOWED BY APPLICABLE LAW, ANY IMPLIED WARRANTIES THAT CANNOT BE DISCLAIMED ARE LIMITED TO
NINETY (90) DAYS FROM THE DATE OF INITIAL DOWNLOAD OR INSTALLATION OF THE SOFTWARE, CONTENT
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AND/OR DATA OR ACCESS OF THE SERVICE BY OR ON BEHALF OF LICENSEE. THE ENTIRE RISK ARISING OUT
OF THE USE OR PERFORMANCE OF THE SERVICE, SOFTWARE, CONTENT, DATA AND DOCUMENTATION
REMAINS WITH LICENSEE.

WITHOUT LIMITING THE GENERALITY OF THE FOREGOING, LICENSEE ACKNOWLEDGES THAT THE DATA MAY
INCLUDE INACCURACIES AND THAT LICENSEE WILL USE COMMON SENSE AND FOLLOW STANDARD SECURITY
PRECAUTIONS IN CONNECTION WITH LICENSEE'S USE OF ANY VULNERABILITY ASSESSMENT RESULTS
GENERATED BY THE SOFTWARE OR THE SERVICE.

VI. WAIVER OF DAMAGES.

TO THE MAXIMUM EXTENT PERMITTED BY APPLICABLE LAW, IN NO EVENT SHALL SYHUNT OR ITS SUPPLIERS
OR LICENSORS BE LIABLE TO LICENSEE OR ANY THIRD PARTY FOR: (A) ANY CLAIM, DEMAND OR ACTION
(IRRESPECTIVE OF THE NATURE OR THE CAUSE OF THE CLAIM, DEMAND OR ACTION) ALLEGING ANY LOSS,
INJURY OR DAMAGES ARISING OUT OF THIS AGREEMENT OR WHICH MAY RESULT FROM THE USE OR
POSSESSION OF THE PRODUCT; (B) ANY LOSS OF PROFIT, REVENUE, CONTRACTS OR SAVINGS, OR ANY
OTHER INDIRECT, INCIDENTAL, SPECIAL, PUNITIVE OR CONSEQUENTIAL DAMAGES ARISING OUT OF
LICENSEE'S USE OF OR INABILITY TO USE THE PRODUCT, ANY DEFECT IN THE PRODUCT, OR THE BREACH OF
THESE TERMS OR CONDITIONS, IN EACH CASE, WHETHER IN AN ACTION IN CONTRACT OR TORT OR BASED ON
A WARRANTY, EVEN IF SYHUNT OR ITS SUPPLIERS OR LICENSORS HAVE BEEN ADVISED OF THE POSSIBILITY
OF SUCH DAMAGES.

VII. LIMITATION OF LIABILITY.

THE TOTAL LIABILITY OF SYHUNT AND ITS SUPPLIERS AND LICENSORS ARISING OUT OF OR IN ANY WAY
RELATED TO THIS AGREEMENT OR ITS IMPLEMENTATION SHALL NOT EXCEED THE AMOUNTS PAID BY
LICENSEE TO SYHUNT UNDER THIS AGREEMENT AND/OR THE THIRD PARTY SUBSCRIPTION TERMS, IF
APPLICABLE. BECAUSE SOME STATES/JURISDICTIONS DO NOT ALLOW THE EXCLUSION OR LIMITATION OF
LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES, THE ABOVE LIMITATION MAY NOT APPLY TO
LICENSEE.

VIII. DISCLAIMER OF ENDORSEMENT.

Reference to any products, services, processes, hypertext links to third parties or other information (by trade name,
trademark, manufacturer, supplier or otherwise) does not necessarily constitute or imply its endorsement, sponsorship or
recommendation by Syhunt or its suppliers or licensors. Product and service information are the sole responsibility of each
individual vendor. The Syhunt Informatica Ltda name and logo, and other trademarks and trade names owned by Syhunt,
may not be used in any commercial manner without the prior written consent of Syhunt.

IX. TERMINATION.

This Agreement shall terminate automatically if Licensee fails to comply with any of the terms and conditions described in
this Agreement. No notice shall be required from Syhunt to effectuate such termination. On termination, Licensee must
destroy all copies of the Software, Service, Content, Data and Documentation. Without limiting the foregoing, Syhunt may
terminate this Agreement immediately for any breach by Licensee of the Terms of Service Agreement, or the Third Party
Subscription Terms if applicable. In the event of any termination by Syhunt pursuant to this Section IX, Licensee shall not
be entitled to any refund of pre-paid subscription fees.

X. INDEMNITY.

Licensee agree to indemnify, defend and hold Syhunt and its parents, subsidiaries, affiliates, suppliers and licensors
(including their respective licensors, suppliers, assignees, subsidiaries, affiliated companies, and the respective officers,
directors, employees, shareholders, agents and representatives of each of them) free and harmless from and against any
liability, loss, injury (including injuries resulting in death), demand, action, cost, expense, or claim of any kind or character,
including but not limited to attorney's fees, arising out of or in connection with any use or possession by Licensee of the
Product.

XI. TERMS OF SERVICE AGREEMENT.

The Terms of Service Agreement is incorporated herein by reference, provided, however, that in the event of any conflict
between the terms and conditions of this Agreement and the terms and conditions of the Terms of Service Agreement, the
terms and conditions of this Agreement shall govern.
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XII. GOVERNING LAW.

The rights and obligations of the parties under this Agreement shall be governed and construed under the laws of the State
of Rio de Janeiro, Brazil, without reference to its conflict of laws principles.

XIII. ENTIRE AGREEMENT.

This Agreement constitutes the complete and exclusive agreement between Syhunt and Licensee with respect to the
subject matter hereof and supersedes all prior oral or written understandings, communications or agreements not
specifically incorporated herein. This Agreement may not be modified except when executed by an authorized
representative of Syhunt and Licensee.

XIV. WAIVER.

The failure of either party to require performance by the other party of any provision hereof shall not affect the full right to
require such performance at any time thereafter, nor shall the waiver by either party of a breach of any provision hereof be
taken or held to be a waiver of such or any other provision.

XV. ASSIGNMENT.

Neither this Agreement nor any rights or obligations of Licensee hereunder may be assigned by Licensee, in whole or in
part, without the prior written approval of Syhunt. Any assignment in derogation of the foregoing shall be null and void.

XVI. SEVERABILITY.

If any part of this Agreement is for any reason found to be unenforceable, all other parts nevertheless remain enforceable
as long as a party's rights under this Agreement are not materially affected. In lieu of the unenforceable provision, the
parties will substitute or add as part of this Agreement a provision that will be as similar as possible in economic and
business objectives as was intended by the unenforceable provision.
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Basic QuickStart
Starting a scan

The Start button in the scan bar starts a scan. Before starting a scan, you must define targets (see below).

If your connection requires the use of a proxy server, you should visit File|Tools|Network Settings.

Defining targets

Click the Target button in the scan bar and select one of the following options:

Host(s) - You can enter a single host or multiple hosts separated by commas. Example: www.host1.com,www.host2.com.

Start URL - You can enter a full URL. Example: http://www.syhunt.com/search.php. If you want to add more than one
start URL, see the Start URLs topic.

Load from file - Allows you to load a list of hosts from a file on your disk.

IP Address - Allows you to enter a numeric IP Address. Depending on the server configuration, you may need to configure
a custom virtual host if you use this option (click the Target Settings button).

IP Range - Allows you to enter a IP Range. You may not be able to configure custom virtual hosts if you use this option
instead of the normal options.

If your target requires the use of host authentication, you can configure it by clicking the Target Settings button.

Additionally, you may want to define target ports (see below).

Defining target ports

The Port(s) field in the scan bar allows you to define target ports. You can enter a single port or multiple ports separated
by commas. Example: 80,443.
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If you enter, for eg, "www.syhunt.com,www.syhunt.com.br" in the hosts field and "80,443" in the ports field, Sandcat will
scan these two ports on syhunt.com and syhunt.com.br and combine results into a single report.

Choosing a scan method

The Common Web Server Scan is the default scan method. The scanner will scan for outdated server software, and
common web server vulnerabilities and exposures. If you want to use a different scan method, click the Scan Method
button in the standard toolbar. You will be able to select one of the following options:

Common Web Server Scan - Scans for outdated server software, common web server vulnerabilities and more.

SANS Top 20 - Scans specifically for the SANS Top Twenty List of Critical Network Vulnerabilities.

Web Application Scan - Identifies flaws in custom web applications. This includes fault injection vulnerabilities such as
XSS, SQL Injection, File Inclusion, and more.

OWASP PHP Top 5 - Scans specifically for the OWASP Top Five List of PHP Vulnerabilities.

Fault Injection - Scans specifically for fault injection vulnerabilities. If this scan method is selected, all other checks that
does not require injection are disabled and Sandcat will then specifically check for SQL injection, XSS, file inclusion, and
similar flaws.

Complete Scan - Scans for both common web server vulnerabilities and web application vulnerabilities. This is the
combination of the common web server scan and the web application scan methods plus some additional checks. A
Complete Scan can sometimes be very time-consuming when performed against a web server that has a large quantity of
web folders (eg: 200 or more web folders).

Complete Scan (No DoS) - Same as before, but with denial-of-service tests disabled.

Note: Sandcat's web application scan is only activated when one of these scan methods are selected: Web Application
Scan, PHP Top 5, Fault Injection, SQL Injection, XSS or Complete Scan. All other scan methods does not include
application checks/spidering. 

Configuring SSL
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If you want to configure SSL, click the SSL button in the scan bar. The following options will be available:

Auto - If this option is enabled, the scanner will automatically choose when to use SSL during the current session.

Enable - If this option is enabled, the scanner will always choose to use SSL.

Disable - If this option is enabled, the scanner will not use SSL.

Configuring additional options

The Options button in the standard toolbar gives you access to general and advanced options (see the Options topic for
more information on the available options). The default options are usually safe enough to accept.

Customizing the report

If you want to customize the report, click the Report button in the standard toolbar. The following options will be available:

Quick Notes - Allows you to add notes to the scan report.

Settings|General Options - Allows you to configure a custom report title, font, and more.

Settings|Colors - Allows you to customize report colors.

Settings|References - Lets you set which references should be included in the report. By default, CVE, BugTraq, and
OSVDB references are enabled.

Customizing checks

If you want to customize checks, click the Checks button in the standard toolbar. The following options will be available:
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Application Checks - Allows you to configure which application tests should be performed. The list includes Common
Files, Extension Checking, Path Disclosure, Source Code Disclosure, and more.

Application Checks|Fault Injection - Allows you to configure which fault injection tests should be performed. The list
include Command Execution, Cross Site Scripting, Directory Listing, and more.

Server Checks - Allows you to configure which server checks should be performed. The list include ASP, CGI,
ColdFusion, Domino, FrontPage, IIS, and more.

Monitoring a scan

Click the Events button in the standard buttons toolbar to see the Events screen. This screen displays information related
to the current scan session (scan progress, found vulnerabilities, and more).

Aborting a scan

The Stop button will stop a scan in progress. This button will be grayed if you have not started a scan.

Generating a report

The Generate a Report button in the File menu allows you to generate reports. This will not be possible if you have not
started a scan. For detailed information about reports, see the Generating Reports topic.

Note: This feature is not available if you are running the free version of Sandcat.
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Options

General

Enable autoupdate - Automatically updates the software. An Internet connection is required.

Enable program sounds - If this option is enabled, the scanner will play a sound when a vulnerability is found.

Use virtual hosts - Only disable this option if your site does not rely on virtual hosts or if you configured a custom virtual
host in the Target Settings screen for the target host. 

Use browser behaviour - When analyzing web sites there are numerous situations on which it is better to behave like a
web browser and less like a robot. This will often increase the Sandcat's accuracy.

User-Agent - Allows you to configure a custom user-agent. By default, the scanner will identify itself as Mozilla.

Scan Settings

Perform reconnaisance - Enables Sandcat to choose the exploits according to the type of web server you are testing,
reducing the assessment time.

Use fast CGI scanning method and Use the maximum optimization level - If these options are enabled, Sandcat will
constantly try to reduce the assessment time during the scan by optimizing checks. Both options have no impact in the
applications scan stage, only in the server scan stage.

TIMEOUT

Pause the scan if there is excessive timeouts - Sandcat will warn if there is excessive timeouts, show
recommendations and pause the scan if this option is enabled.

Filters

Filter invalid server responses, Use intelligent filtering and Use anti-redirect filtering - These options have been
developed for minimizing false positives and will never limit the depth of the analysis. If you disabled them you may get a
few false positives, specially during the server scan stage.

IGNORE LIST

Ignore common unnecessary URL/form parameters and Ignore common unnecessary extensions - These options
have been mainly developed for speeding up scans and increase the accuracy of the fault-injection checks. Disabling
these options may cause issues while performing crawling and application checks. Both options have no impact in the
server scan stage, only in the application scan stage.
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Generating Reports
Sandcat Reports

Sandcat allows to edit the report information before saving or emailing them. You can generate reports multiple times using
data stored from current and past sessions. It is possible to use different templates, export data, select the information
that should be added, add notes, and if required you can develop your own templates and data exporting formats.

Previously generated reports can be viewed and managed using the Report Manager tool (see View|Reports).

Data from past sessions can be managed using the Session Manager tool (see View|Sessions). This is the tool
responsible for generating reports.

Generating Reports

To load a past session, you should use the Session Manager tool (see View|Sessions).

Double-click a session name to load the session information and you will be able to generate reports for the session you
selected. After clicking "Generate a Report", and selecting the output format, you can choose a place to save the report.

It is also possible to drop items from a report. By changing the Include option to "no", the item will not be included in the
report. You should perform this action before generating a report.

Automatically Emailing Reports

Sandcat can be configured to automatically email reports after a scan is completed. Multiple recipients can be entered,
and it is also possible to configure different mail addresses for each host if required. In order to achieve this:

1. Configure the email settings (see Tools|Email Options)

2. If you want to configure specific mail address for a host, click the Target Settings button in the scan toolbar and go to
the Email Alert tab.

3. Do not forget to enable the email alert feature (to do this click the Options button in the standard buttons toolbar, and
enable the "Automatically email scan results" option in the Reporting screen)

Using the Report Manager

Viewing a report

Double-click the report to open it. The report will open it in your default browser.

Copying a report
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To copy a specific report to a folder, select the report and click the Copy To option.

Deleting a report

To delete a specific report, select the report and click the Delete option.

Deleting all reports

If you want to delete all reports, select Tools|Clear Report Data.

Sandcat Extensions and Theme Support
Sandcat Extensions

Sandcat Extensions are available via packages with .scx (SandCat EXtension) extension, which should be copied to the
Apps subfolder. Menu Tools/Extensions displays all available extensions and allows to configure them.

Before running Sandcat it is necessary to install Python 2.5 (or the latest available version) or most extensions will not be
available. The Update Checker extension, for eg, will not work if a Python installation is not found.

Python is free and can be downloaded from:
http://www.python.org/download/

Note: Extensions support can be disabled (see Options -> General)

Sandcat Theme Support

Sandcat Themes are available via packages with .thm extension, which should be copied to the Themes subfolder.

Menu Tools/Themes displays all available themes and allows to switch between themes.

Note: Theme support can be disabled (see Options -> General -> GUI Preferences)

Info for Contributors

With the release of Sandcat 3.5, Contributors can now take part in the evolution of Sandcat in the GUI front. 

The first preview of the Sandcat Development Kit is already available for download.

The Sandcat DevKit includes:
- An overview of the GUI and Extension Technologies
- The Sandcat GUI Source
- Extensions Examples
- Details on how to create an extension manifest file and more

Note: Currently only Sandcat Premium users and partners have access to this preview.

Sandcat GUI Source

All files used to define the Sandcat GUI can be found in the SandcatUI subfolder of the Sandcat DevKit.

Most files are HTML or images. Files with .opt extension define the options available in the Options and Checks screens.

Extensions Examples

Sandcat 3

http://www.python.org/download/


We've created four extensions for Sandcat which we expect to serve as the basis for the development of new extensions
and
suggestions that will allow us to enhance the Sandcat extension system:

Update Checker - Checks for updates during startup

DoS Warning - Warns when the Denial-of-Service check is enabled and allows to disable it from the home

Emails - Displays a list of emails found by Sandcat in the current scanned host

Links - Displays a list of links found by Sandcat in the current scanned host

The source code of these extensions is available in the Extensions subfolder of the Sandcat DevKit.

Extension Configuration Screen

Configuration screens for extensions can be easily generated using the same format that the Sandcat GUI uses (the
Updcheck extension includes an example of this, more specifically the Updcheck.opt file).

Syhunt Packer

The Syhunt Packer application (responsible for generating SCX and THM files) can be found in the Sypacker subfolder of
the Sandcat DevKit. 

Usage examples:

Sypacker *.* [extensionname].scx
Sypacker *.* [themename].thm

FAQs

Why call it "Extensions" and not "Plugins"?
Plugins are often slightly different from extensions. We think that our system fits more in the category of extensions rather
than plugins. Sandcat Extensions can add new features to the Sandcat application. Each extension usually consists of a
single file with SCX extension. SCX stands for SandCat eXtension.

The previous Sandcat versions included a plugin system in beta stage. Is this the current Sandcat Extensions
Platform that evolved?

Not exactly. The plugin system included in the previous Sandcat versions was specifically for developing open exploits.
Our goal was to develop a simpler open plugin system for developing HTTP exploits. However the number of new server
and application vulnerabilities disclosed every month is so big that even advanced Sandcat users prefer us to handle the
exploits development and research.

Is the Sandcat Extension system mature?
The Sandcat Extensions Platform is still under development. We expect it to become more advanced over time.

What language can be used for developing a SCX?
Python language is used for extensions development. Some knowledge of HTML and CSS (Cascading Style Sheets) is
also required.

Contact

Questions, comments, suggestions, or contributions are all welcome and can be sent via email to:
sandcatdev@syhunt.com
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Info on Specific Features
Command Line Support

Sandcat's main executables are "Sandcat.exe" (GUI), "Srvcheck.exe" (server scanner) and "Secrobot.exe" (application
scanner), the last one responsible for the execution of the application checks. Below you will find detailed info about the
supported commands.

Sandcat Server Scanner

Any or all of the following parameters may be passed via command-line.

Srvcheck.exe [Target] [Port] [Parameters]

Sample 1 (Single Host Scan):

Srvcheck.exe 127.0.0.1 80 -h -sr:normal -start

Sample 2 (IP Range Scan):

Srvcheck.exe 127.0.0.1-15 80 -r

Supported command-line parameters are:

-h => Single Host Scan
-r => IP Range Scan
-sr:normal => Normal Scan
-sr:complete => Complete Scan
-sr:cmpnodos => Complete Scan (No DoS)
-sr:top20 => SANS Top 20 Scan
-start => Automatically perform scan
-close => Automatically close after running
-xml => Enable XML reports
-ssl => Enable SSL
-sl:1 => Scanning Level 1 (High Performance)
-sl:2 => Scanning Level 2 (Medium Performance)
-sl:3 => Scanning Level 3 (Low Performance)
-nosnd => Disable warning sound
-vhosts => Use virtual hosts
-nocache => Make no-cache requests
-malert => Use MailAlert
-evadids => Evade IDS
-nodos => Disable DoS Tests
-eslow => Enable the slowdown mechanism
-igne => Automatically ignore errors

Sandcat Application Scanner

Any or all of the following parameters may be passed via command-line.

Secrobot.exe [Target] [Port] [Parameters]

Supported command-line parameters are:

-url:[url] => Start URL (eg. index.php, if not used ""
will be assigned)
-start => Automatically perform scan
-close => Automatically close after running
-sr:normal => Normal Scan
-sr:complete => Complete Scan
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-sr:faultinj => Fault Injection
-sr:sqlinj => SQL Injection
-sr:xss => XSS (Cross-Site Scripting)
-sr:phptop5 => OWASP PHP Top 5 Scan
-xml => Enable XML reports
-ssl => Enable SSL
-nodos => Disable DoS Tests
-eslow => Enable the slowdown mechanism
-igne => Automatically ignore errors

Sandcat Log Analysis Tool

Any or all of the following parameters may be passed via
command-line. Results are saved to the Logs folder.

Logcheck.exe [Web Server Log] [Parameters]

Supported command-line parameters are:

-start => Automatically perform scan
-close => Automatically close after running
-sl:1 => Scanning Level 1 (High Performance)
-sl:2 => Scanning Level 2 (Medium Performance)
-sl:3 => Scanning Level 3 (Low Performance)
-nores => Disable IP to Name Resolution

Sandcat Report Editor (Codename Hermes)

Any or all of the following parameters may be passed via command-line.

Note: Sandcat will not interact with Hermes if executed as individual modules. Reports will be instead automatically saved
in the root of the "Rep"and "Spd" folders. This is a limitation, which will probably be removed in future versions. You can
use parameters -start and -close to automatically start the scan and close the software after the scan is completed, and
you can also specify the -malert parameter if you want to automatically email the reports in the end of the assessment (a
copy of the report will then also be available in the "Sent" folder).

Hermes.exe [Session Name] [Report Type] [Parameters]

Sample 1 (Editing Report Data):
Hermes.exe 10-17-2006_04.08.09

Sample 2 (Generating a Report):
Hermes.exe 10-17-2006_04.08.09 Standard -genreport

Sample 3 (Generating and Emailing a Report):
Hermes.exe 10-17-2006_04.08.09 -genreport -email

Supported command-line parameters are:

-genreport => Automatically generate report
-email => Automatically email the report
-close => Automatically close after running

Scan Methods

Common Web Server Scan: Srvcheck.exe + -sr:complete
SANS Top 20: Srvcheck.exe + -sr:top20
Web Application Scan: Secrobot.exe + -sr:complete
Fault Injection: Secrobot.exe + -sr:faultinj
Complete Scan: Srvcheck.exe + sr:complete -and- Secrobot.exe + -sr:complete
Complete Scan (No DoS): Srvcheck.exe + sr:complete + -nodos -and- Secrobot.exe + -sr:complete -nodos
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SSL Support

SSL support in the Sandcat scanner relies on two Dynamic Link Library (DLL) files, SSLeay32.DLL and libeay32.DLL,
developed by the OpenSSL Project. When these two DLL files are present then SSL support is available, which means
that you can scan secure sites with "https" addresses.

When these two DLL files are not present you cannot use SSL to securely access "https" addresses. You can still scan
regular "http" addresses.

OpenSSL Installation

The OpenSLL DLL files Ssleay32.dll and Libeay32.dll do not require any special installation procedure. They just need to
be present in order to be automaticaly utilized by the scanner.

The standard Syhunt Sandcat Setup kit copies the OpenSSL DLLs Ssleay32.dll and Libeay32.dll to the installation
directory. The
standard ZIP distribution includes these files. But they are strictly optional.

The OpenSSL DLL files are not necessary for the normal functioning of the Syhunt Sandcat scanner. If the OpenSSL DLL
files are not present, the scanner still operates normally but without SSL support.

The scanner automatically detects and adjusts to the presence or absence of the OpenSSL DLLs. You can also manually
select the SSL support style via the "SSL" option in the scanner toolbar.

Alternative SSL Support

If for any reason you don't want to use the built-in SSL feature, you can use the stunnel (http://www.stunnel.org/) tool as a
replacement.

Both stunnel and the Sandcat's built-in SSL feature rely on SSLeay

Using Client Certificates

Fill in the target and click the Target Settings button (the Target Settings button is in the left of the green arrow button).
The Certificates tab allows you to configure the client certificates.

Login Credentials

You can configure login credentials in the Target Settings screen (Authentication tab). This option is available via the
toolbar, after the SSL button. It is necessary to enter a target host (or hosts) before accessing it.
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Scan Methods

There are different scan methods that can be chosen in Sandcat and it is possible to customize scan settings for each
target host. See Basic QuickStart for detailed information on this.

Configuring Start URLs

If you need to scan links that are not referenced in any page, here is the procedure:

1. Enter the host name or IP address in the hosts field.

2. Click the Target Settings button in the toolbar.

3. Use the Start URLs tab to add the unreferenced URLs.
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Sandcat will always start from the root (unless you have configured a specific directory). The Miscellaneous tab allows you
to configure a specific directory (using the Virtual Directory field).

Target Definition

Sandcat allows to manually enter hosts, IP address, IP range or load the list of hosts from an external list file. See Basic
QuickStart for detailed information on this.

The Sandcat Folders

Apps - Sandcat Extensions
Config - Sandcat User Configuration
Hosts - Temporary scan data
Lang - Language files
Logs - Packet and log files
Sent - Emailed scan results
Snd - Sound files
Spd - Mining/spidering scan results
Rep - Reports and session-related data
Temp_upd - Temporary SmartUpdate files
Themes - Sandcat Themes

Custom User Files

Config/Logfmt - Custom log format files for the Log Analysis Tool.
Config/Templates - Custom templates (for generating reports or exporting scan data).
Exploits - This folder is now reserved for custom server checks (checks created by the user)

Obsolete Folders

There are numerous files and folders (some listed below) that have no use anymore with the new Sandcat version. Run
Cleanup.bat (located in the root of the Sandcat installation) to remove them.

Conf - Log file format files used by the Log Analysis tool.
Db - This folder is reserved for custom server checks (checks created by the user)
Himgs - Images used by the Hermes (Report Editor) module.
Plc - Report/Data export templates and main configuration file
Plugins - This folder is reserved for plugins (beta feature)

Virtual Directory in Sandcat

The Sandcat server checks will be executed in the root folder unless the Virtual Directory option is configured. The virtual
directory option allows the scanner to focus all its attention on a specific directory (eg, /~syhunt).

To set a virtual directory, you must first enter a target host in the address field. Click Target Settings button and you will
get access to a new screen. The virtual directory field is located in the Miscellaneous tab.
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Web Form Login

If your web site requires authentication prior to allowing access to all or most of the website contents, then the success of
the authentication stage is absolutely crucial. If it fails, for eg, during a Complete Scan, many checks will still be
performed (during the server checks stage), but the application checks, which is the second and most important part of the
scan, will not be performed. 

Sandcat can detect most form logins, but some of them may not be automatically recognized if they have unusual
characteristics. If you ever face this problem, you can teach Sandcat to log into the application.

Let's suppose you are having an issue with Sandcat with the following web form login:

<div class="InputLine"><input name="UserBox" id="UserBox" type="text" class="InputBox"/>User Name</div>
<div class="InputLine"><input name="PasswordBox" id="PasswordBox" type="password" class="InputBox"
>Password<div>

The following procedure will reprogram Sandcat to recognize the form login:

1) Enter the username and password in the "Authentication (Form)" tab in the Target Settings screen (see the screenshot
below). If you have already made this, go to step 2.

2) Now go to menu Advanced in the main Sandcat screen menu and select the "Form Inputs" menu option. Double-click
"List of common form values" and add the following values:

UserBox=@sandcat_web_form_username
--and--
PasswordBox=@sandcat_web_form_password

Values after "=" are internal variables, this ensures that the web form login information entered in the target settings screen
is used in the two form inputs specified (UserBox and PasswordBox).
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Sandcat is now ready to detect this form login.

Bypassing Login Pages

There's also an alternate way to bypass the login page. You have to log into the application using your web browser, and
copy the cookie after logging in (you can do this using for eg, the Firefox's Add N Edit Cookies add-on (
http://addneditcookies.mozdev.org/), or a packet sniffer (such as the freeware Wireshark - http://www.wireshark.org/) if it is
not HTTPs connection). Open the target settings screen and go to the last tab (Miscellaneous) and paste the cookie in the
"Custom cookie" field.

Preventing Logout

Sandcat can also detect most logout pages, but this can fail sometimes if the logout page does not match common
patterns. Add the logout page URL to your current config (see menu Advanced|Logout Pages). This will prevent Sandcat
from accidentally logging out. 
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Request and Response Logging
Sandcat packets are saved in the Logs/[session name] subfolder using the .pkt extension. You can see the packet logs
using the Request Viewer utility (see View|Requests). If you open these files using Notepad, or any other text editor, you
will notice that it is text file format, and the request and response is stored in comma text format. By default, Sandcat only
logs suspicious responses, test errors or tests that returned positive for the presence of vulnerabilities.

To enable the full request/response logging feature, see Options > Logging. The full log will be available in the Logs folder
under the name "Pkt[current date][time].log".

Note: The full log will usually contain a huge amount of data. Additional disk space may be required for this.

Using the Request Viewer

Requests can be reviewed and managed using the Request Viewer tool (see View|Requests).

Note: This will only work if Sandcat is configured to log packets (requests and responses).

Viewing a request

Click the request to open it. Request data will be available on the bottom of the Request Viewer screen.

Editing and resending a request

To edit and resend a specific request, select the request and click the Edit Request option on the main screen.

Deleting a request

To delete a specific request, select the request and click the Delete option.

Deleting all requests

If you want to delete all requests, select Tools|Clear Request Data. 
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Tips
Backing Up the Configuration

Sandcat does not store any important data in the Windows registry. All the important data is stored in the Sandcat folder
(in the Config subfolder), unless custom folders are configured. In order to backup the Sandcat data you just need to
create a copy of the Sandcat folder.

Note: The Sandcat setup creates a file called "Trstapp.inf" in the Windows folder. This file contains the path were Sandcat
was installed.

Better Performance on Old Machines

Intense processing is required during some tests, specially if multithread is enabled (it is enabled by default).

If you disable multithread, CPU usage will be less intense (you can do this by clicking Options in the toolbar and
unchecking the Enable multithread option). 

Choosing the Scan Method

Because the Complete Scan method can sometimes be extensive and a bit time consuming, most users prefer to split up
the assessment by using different scan methods - Common Web Server Scan and then Web Application Scan.

The Common Web Server Scan equals to the first part of the Complete Scan Method, which will look for common
vulnerabilities (no crawling performed) in a very similar way to CGI scanners. The Web Application Scan equals to the
second part, which crawls the web site and performs attacks against the web site structure and the web applications.

If you only want to scan your web applications for common web application vulnerabilities you can choose a third option,
the Fault Injection scan method. This scan method equals to the second part of the Web Application Scan method.

There are two ways to speed up the Web Application Scan (or the Fault Injection scan method):

- Limiting the crawling depth/providing a list of folders and extensions to ignore (this can be done in Options -> Filters).

- Saving the link list of your scan (after it has ended) and then importing the link list as Start URLs in the next scan (this
can be done in the Target Settings screen, Sandcat will remember the settings after this).

Evading Security Mechanisms

If you want to attempt to avoid IDS detection and application firewalls, you can try the following configuration:

Keep the "Enable IDS Evasion" option checked - Our IDS evasion feature is the most advanced and compreehensive.
Some IDS software, however, have evolved to avoid anti-IDS techniques.

Disable DoS Tests - Denial-of-Service tests will always generate many IDS warnings. Disable it.

Enable the "Eliminate PUT/POST/DELETE requests" option - These types of requests may also generate many IDS
warnings.

Enable the slowdown option - This will make the scanner wait a few milliseconds before starting each check. You may
also want to specify the slowdown time - see the Slowdown (ms) option.
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Minimizing False Positives

There are many ways to minimize false positives in Sandcat. It is possible to configure custom error page detection
signatures (global or host-specific) and create custom signatures to validate findings of specific web application security
checks.

Note: Please be careful while making some changes to the product, such as creating user signatures for detecting
application vulnerabilities. Sandcat already contains signatures for detecting these vulnerabilities. If the quality of your
signatures are bad, the detection accuracy may decrease, and then false positives or negatives can happen. It is better
(and safe) to rely on its default signatures.

Sandcat is a highly customizable software, you should not have any problems customizing your scans. If you miss some
feature, drop us an email. Many customization features that are available today were derived from customer suggestions.

Error Page Signatures

Sandcat Signatures apply to both the web application scan and the web server scan modules. If you use the
Advanced/Error Pages menu option to add/remove error page detection signatures, it will be a global setting (that applies
to all hosts).

If you add a signature using the Request Viewer, it will be host specific, not a global setting that applies to all hosts. The
target settings screen of the Sandcat GUI also allows you to see and edit these host specific signatures. You can also
edit the same signatures via the Tools menu in the Request Viewer utility. 

Request Timeout Errors

Sandcat may sometimes show a notification of timeout during a scan. Timeout errors relates to the time the webserver
takes to respond. Don't worry if there is a small number of timeouts. Sandcat was developed to retry* these requests. But
when this happens too many times, you should:

1) Check what is the timeout config that is currently being used - You can try doubling or trippling the timeout value in ms
in the Options screen.

2) Consider decreasing the number of threads

3) Consider disabling the multithread feature - all packets will be sequential, and then you can check if the timeout error
still occur.

(*) The latest Sandcat versions will automatically retry the request if there is a timeout (unless you change the number of
retries to 0). 

Speeding Up Sandcat

Here is how to make Sandcat even more fast.

In Options -> General:

    * Keep Enable multithread checked
    * Additionally, try increasing the Maximum number of threads.

In Options -> Scan Settings:

    * Keep the reconnaissance, fast CGI scanning and maximum optimization options enabled
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    * Keep triple checking disabled - Specially if the target server is not case-sensitive

In Options -> Filters:

    * Limit the crawling depth (if possible)
    * Provide a list of folders and extensions to ignore

In Options -> IDS Evasion:

    * Keep IDS Evasion disabled

In Options -> Logging:

    * Keep the "Log all packets" option disabled

In the Target Settings screen:

    * Import the link list of your last scan as Start URLs
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FAQs
Basic FAQs

How many time Sandcat will take to run all the tests?
Duration depends on the number of pages and applications your website contains and the scan method you selected. The
web application checks (crawling stage) is usually the part of the scan that can take more time and depends on the size of
the target site.

Can I increase the number of threads?
Yes, you can. Sandcat was coded to detect and inform about performance problems during the scan. Just keep an eye in
the Events screen. If you see a large number of timeouts then your system (or the target system) is not handling it well.
Don't worry if there is a small number of timeouts. Sandcat was coded to retry these requests.

Can I load a previous scan session and re-run reports again?
Yes, this is possible since the 3.0 release. Select the View option from the menubar and then Sessions. The Session
Manager screen will open. Double click the name of the previous session you want and you will see the session results
and the options to export data and generate reports.

How Sandcat comes up with it's rankings (high, medium, low, etc)?
The Sandcat rankings are based on vulnerability categories and sometimes on individual vulnerabilities and sometimes on
the server's response to specific requests. Currently you can also easily group these vulnerabilities by generating a
compliance report (just choose the compliance option when saving a report).

Is there a list of tests that are conducted using the updated version of Sandcat?
You can get an idea of the tests by clicking the menu About, and then select "Vulnerability List". See 
http://www.syhunt.com/section.php?id=updates for the last update. This page gives you some idea of what gets added to
Sandcat every month.

Are these tests CVE compliant?
Not all the checks have CVE numbers, but anything with a CVE is included in the scanner. So, any exploit that has been
posted to forums like Bugtraq is in there as well, in addition to variations on exploits. For example, Sandcat checks for
several hundred forms of the Unicode exploit. There are also filters to prevent false-positives on all these checks.

Do any of the tests crash the tested host?
As far as crashing the host - there are denial of service checks which may crash the tested host - you can turn those off
when scanning though.

Is there any way to provide a list of IP addresses (not necessarily in the same range) for scanning?
Yes. See Basic QuickStart for detailed information on this.

How can I configure the DB Update?
You should enter these in the Login screen:

   1. Start Sandcat
   2. Click the menu File-> Login option
   3. Fill in your username and password. Note that they are case sensitive. And press Connect.

When was Sandcat's last database update?
See http://www.syhunt.com/index.php?section=resources.updates for the last update.

Does Sandcat have any problems with personal firewalls?
Yes, you'll just have to let the firewall know that Sandcat is authorized to make connections to the Internet. However,
some software firewalls do not handle high loads very well. It is not recommended to run both a personal firewall and
Sandcat on the same machine.

If you're running a PC firewall on the scanning system that does outbound filtering, try disabling it - we've occassionally
seen firewalls automatically block a program's socket calls without first prompting the user as to whether or not it should
be allowed to make connections.

Is there any way to scan ports 23 (telnet) and 21 (ftp)?
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Sandcat is not a general purpose security scanner, it is specialized for evaluating web servers. The port option is just there
for HTTP servers that happen to run on something other than 80.

Is there any way to use a proxy server for web scanning?
Does your net connection require a proxy server for web access? If so, you'd have to configure Sandcat with that
information. Sandcat will ask for this information after the installation. Using proxy servers for HTTP scanning is also
possible, but not recommended.

I am testing a system that has webservers running on ports other then 80. How do I scan those webservers with
Sandcat? 
There is a ports field you can use. It is located in a toolbar on the right side of the Sandcat GUI. You can replace the
default port value with the port value you need or you can specify more than one ports separated by commas.

Injection & Spidering

Q: What inputs it checks and how it determines if it has found SQL injection or cross-site scripting?

A: Everything starts with the index page of the target website, some additional specific remote files (such as robots.txt)
that may be available, and URLs specified as Start URLs by the user (this one optional).

Sandcat will then map the entire site structure until reaching the maximum depth limit, which means all the web site
pages. During the html parsing, it will extract and compile information about all the web site links, forms, folders,
applications, etc, everything that can be analyzed and targeted. Parts of these web pages are instantaneously analyzed
(for dangerous comments, email form hijacking, unencrypted login and such), while other parts, like fault injection checks,
are left for the end. They take place after the spidering stage.

During the fault injection stage, Sandcat then targets all the forms and URLs. Form and URL parameters are manipulated
in many different ways and sequences in the entire website. It will fill in forms using common form inputs (eg, if it asks for
city information, it will use New York). After the submission is completed, Sandcat analyzes the web server's response
and checks if there is any sign of success.

Q: In reference to the Wikipedia article on XSS, what types of XSS attacks are detected by Sandcat?

A: Types 1 and 2 described in the Wikipedia article are extensively covered. Type 1 is actually what we refer as "URL
manipulation" in our documentation. Type 2 is what we refer as "form field manipulation". Type-0 attack is not covered
because it is not specifically a server or web application flaw.

Name Changes

What happened to Sandcat Platinum and TrustSight?
Sandcat Platinum was renamed to Sandcat Pro (or Professional) a few years ago. The TrustSight technology was
absorbed into the Sandcat software.

What happened to Collapse?
Collapse is now the main GUI application of Sandcat. It integrates all the functionality of Sandcat. It is still possible,
however, to start the Sandcat Scanner and Miner modules as individual applications (via the Tools menu).

FAQs for New Users

Q: I´m interested in tests such as SQL injection, cross site scripting etc. Does Syhunt perform such tests?

A: Yes, Sandcat does extensively perform these tests and lots of other fault injection tests. Please, check out
http://www.syhunt.com/index.php?section=sandcat.checks for more detailed info.

Q: If there is a code change to the web application, then will the Syhunt tool natively detect the vulnerability or
does Syhunt also have to upgrade the scanning tool?

A: The Syhunt's web application scanner is able to test custom-built web applications. This means that if a code is
changed and the application becomes vulnerable from one moment to the next to some common type of attack (XSS, SQL
Injection, and other web attacks), the web application scanner will be able to detect and report the issue.
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Q: The web site says Sandcat is free. Is this correct?

A: Sandcat is available in two editions - free and professional. The free edition does not include automatic updates,
reporting features, add-ons and other critical features.

Q: What is the difference between the free copy and the Pro Edition?

A: Please visit http://www.syhunt.com/index.php?section=sandcatpro.pricing for detailed info on this.

Q: Whether the Sandcat product looked at all webpages on my host, as by default, there are no links on the
main site?

A: Sandcat will not only map and test applications for web application flaws. It will also try to locate common files and
folders, database files, common vulnerable scripts, backup files, common backup folders and files in the root folder and all
referenced subdirectories (if there are no subdirs, then it will be restricted to the web server root). These files and folders,
that Sandcat will also try to expose and analyze, are not necessarily linked in any way to any web content.

Sandcat and Web Application Security

1. How easy is Sandcat to use? Can the average network administrator really identify problems with their web
servers and applications?
Sandcat is a highly customizable solution and can adapt to almost any scenario. It has a clean and simple GUI. The
default settings are usually adequate, but can also be adjusted for each target. The session information compiled and
stored during a scan can be used to review data, re-send requests, generate pass/fail reports, and also can be exported to
multiple file formats.

2. How does Sandcat prevent false positives?
Multiple methods are used to prevent false positives, such as analyzing the server's response for signs of the vulnerability
being tested for. We advised users to be careful while making some changes to the product, such as creating user
signatures for detecting application vulnerabilities. Sandcat already contains signatures for detecting these vulnerabilities. If
the quality of the user's signatures are bad, the detection accuracy may decrease, and then false positives or negatives
can happen. It is better to leave this to the experts and rely on its default signatures. If you're a security expert, okay, then
go on and Sandcat may yield even better results after some sophisticated fine tuning.

3. How is Sandcat likely to change in the coming releases? Do you have plans to support AJAX and other
emerging application technologies?
We've been expanding the Sandcat scanning features according to the emerging technologies. We know that
organizations are going to have even more complex websites with the adoption of technologies such as AJAX, and we have
to be prepared to help these organizations secure their sites. Sandcat 3.0 is already able to exploit AJAX-based web
applications. Emerging application technologies, all will be supported.

4. Besides scanning, what other things should network admins be doing to secure their environment? Can
Sandcat help them with these tasks?
Sandcat includes a web server hardening tool. While performing, for example, an OWASP PHP Top 5 scan, Sandcat will
cover items P1 (remote code execution), P2 (cross-site scripting), P3 (SQL Injection) and P5 (file system attacks) and it
would be necessary to manually check the PHP configuration to check compliance with the P4 item (PHP configuration) of
the OWASP PHP Top 5 guideline. The PHP configuration cannot be properly analyzed from the network. This can only be
done locally, by having access to the configuration file. Once you have access to the PHP configuration, the Sandcat
Hardener can automate the configuration analysis. The tool will evaluate the security threats and identify appropriate
countermeasures. This is one of the software's unique features. Sandcat is the first web application scanner that can
address all the OWASP PHP Top 5 guideline items.

5. What are attackers looking for in victim systems? How are they attacking applications today? What do you
think will be the source for new attacks in the future?
Right now we're concerned about known and unknown PHP and ASP vulnerabilities. Every day numerous vulnerabilities
are being discovered in various web systems and new entries are created for these vulnerabilities in databases worldwide.
Web applications are becoming more and more complex and hackers are taking advantage of it to exploit systems.

6. What about web server worms? It has been a long time since NIMDA and Code Red. Will we see future
web-based worms as dangerous as those were, or are they a thing of the past?
Traditional viruses are thing of the past, dangerous worms not. The first AJAX worms have already been developed. At least
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organizations are more prepared than they were in 2001 to defeat worms.

7. How does Sandcat protect against threats like SQL Injection, Cross Site Scripting and Buffer Overflows? Can
the tool be used to help Quality Assurance teams make sure web applications are safe before they go into
production?
To detect these vulnerabilities, Sandcat relies on numerous URL/form parameter manipulation techniques. Sandcat is also
able to find known vulnerable scripts in the web server's tree, even if they are not linked anywhere, and then exploit these
scripts. This is a more advanced approach.

A special attention has been given to the the SANS Top Twenty, the OWASP's Top 10 and PHP Top 5 guidelines.
Sandcat 3 is able to generate compliance reports, listing all of the web servers that do not comply with these main
guidelines and standards, and specifying details and recommendations.
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Updates
Updating Sandcat -- Members Only

Sandcat includes a SmartUpdate tool, this tool automates the engine and database updates. You can retrieve the latest
version and updates using this utility (just select menu Tools, SmartUpdate, and it will download and install the latest
updates).

Or you can manually download and install the updates at http://www.syhunt.com/index.php?section=members.home.

If the automatic update feature is enabled*, you will see notifications about updates in the Sandcat GUI. Click "Install" and
Sandcat will download and install the new components.

(*) In the newest versions of Sandcat the update checking is performed by a Sandcat extension called Update Checker.
This extension is enabled by default. In order to execute both the Update Checker and the SmartUpdate application you
need Internet access, more specifically HTTP protocol. 

Note: Syhunt offers regular monthly/weekly updates, and immediate updates, depending on the risk associated with the
new vulnerabilities. The free edition doesn't give you access to the latest product updates. You may lose in performance
and ignore important security checks that are only available in the latest components and databases.

Release Notes

Version 3.5

NEW INTERFACE

    * New themeable and extensible GUI, which is built using new standards.

    * Menu Tools/Themes displays all available themes and allows to switch between themes.

    * Menu Tools/Extensions displays all available extensions and allows to configure them.

    * Sandcat will now automatically remember the last toolbar position.

    * New redesigned configuration screen (for Options & Checks). The new Checks screen allows to enable or disable
multiple checks with a single click.

    * Many thanks to Paul Woroshow for pointing us into this direction.

SETTINGS STORAGE CHANGES

    * Sandcat (and its modules) now stores all settings in the Config subfolder. For this reason, your settings (from the
previous version) will not be detected by Sandcat. To import your previous settings, use the Load Settings option in the
File menu. Settings from the previous release will be located in the Plc subfolder (in the General.cfg file).
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    * The Target Settings specifically are now stored using a different format. Previous settings (using the old format) will not
be detected and have to be re-entered in the Target Settings screen. If you have created settings for a big number of hosts,
and this is a problem, please contact us and we will provide you with a conversion utility.

EXECUTABLE NAME CHANGES

    * For those running the Sandcat modules individually from the command line, it is now necessary to use different
executable names. If you've created any shortcuts, you also have to update them. You can find the new executable names
below.

    Sandcat Server Scanner - Renamed to Srvcheck.exe
    Sandcat Log Analyzer - Renamed to Logcheck.exe
    Sandcat App. Scanner - Renamed to Secrobot.exe (previously known as Miner)

SANDCAT EXTENSIONS AND THEME SUPPORT

    * Extensions and Themes are available via compressed packages with extensions .scx (SandCat EXtension) and .thm,
which should be copied to the Apps or Themes subfolder respectively.

    * Sandcat Extensions can be written in Python or Pascal. Before running Sandcat it is recommended to install Python
2.5 (or the latest available version) or these extensions will not be available. The Update Checker extension, for eg, has
been written in Python language and will not work if a Python installation is not found.

    * We plan to enhance the extensions support, add new extensions on a regular basis and also create a site for
user-made extensions in the near future.

CREATING NEW EXTENSIONS AND THEMES

    * It is very easy to create new extensions, integrate them to the GUI and even create a configuration screen for these
extensions. You just need some knowledge of HTML/CSS and Python or Pascal programming language. GUI screen
replacements can also be created. More details will be available separately.

OTHER ENHANCEMENTS AND CHANGES

    * Improved multithread functionality.

    * Packet files are now automatically saved in the Logs/[Session Name]/ subfolder.

    * Custom log format files must now be placed in the Config/Logfmt subfolder.

    * Custom templates should be placed in the Config/Templates subfolder.

    * Custom File Checks - Customfc.inf file has no use anymore. Please use Config/Customfc.lst instead.

    * Have you created any custom server checks? They must be placed in the Exploits subfolder. The Db subfolder has no
use anymore.

    * Custom exploits using script format are not supported anymore. We plan to develop a similar, but enhanced and
simplified feature in the future.

    * Smaller setup.

CLEAN UP

There are numerous files and folders that have no use anymore with the new version. Run Cleanup.bat (located in the root
of the Sandcat installation) to remove them.

BUG FIXES

    * Fixed display of scan progress during the end of the Application Checks stage.
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    * Fixed a single timeout occurring during the execution of the Outdated Server Software Test.

    * Fixed an exception error occurring sometimes after the execution of the Recon stage.

    * Fixed timeouts occurring sometimes during the scans. This was often not an issue because of the check retry feature.

    * Fixed a protocol modification that was causing 100% CPU usage during scans in the 3.4 version.

    * Fixed a typo in the Log Analyzer screen. Many thanks to Glenn Blair for reporting this.

Version 3.4.0.3

    * Added new server checks.

    * Updated documentation.

Version 3.4.0.2

    * Minor improvements.

Version 3.4.0.1

    * Minor improvements.

Version 3.4

    * Enhanced support for large websites.

    * Improved speed.

    * Fixed a few false positives.

    * Minor fixes and improvements.

Version 3.3.2

    * Enhanced support for different environments.

    * Enhanced email collection.

    * Vulnerability details screen now allows to edit vulnerability description and recommendations. Vulnerability details can
also be edited using the Report Editor utility.

    * Notifications related to the Maximum URL length restriction now contain the exact URL ignored.

    * Improved GUI performance.

    * Fixed bug related to certificate filenames.

    * Fixed small bug in displaying vulnerability information for a few specific web app sec checks in the main Sandcat or
Report Editor screen.

Version 3.3.1

    * Improved speed.

    * Improved timeout handling. Timeout verification is now restricted to requests.

Version 3.3
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    * Added Resume Feature -- Ability to stop and later resume a scan session. It works for all scan methods and target
options. A past session can be loaded from the main screen or via the File menu ("Load session" option).

    * Added ability to configure a maximum cookie size and the maximum number of cookies per server. (See Options ->
General)

    * Improved memory usage and long-term stability (specially when dealing with a large list of targets)

    * Report graphics are now automatically regenerated after edits. If you are using a custom template based on the
original Sandcat HTML or PDF report template, you will need to update it. Detailed instructions are available below.

    * Vulnerability details screen can now display user modifications.

    * Additional optimizations were made to speed up scans.

    * GUI Preferences is now available as a subitem in Options panel.

    * Minor fixes and improvements.

FIXING YOUR CUSTOM HTML/PDF REPORT TEMPLATES

    * This is only necessary if you have created any custom HTML/PDF report templates.

    * Find and replace the following texts:

    Find: <$value:pie chart 1$>
    Replace with: <$report_session$>\<$value:host$>_1.jpg

    Find: <$value:pie chart 2$>
    Replace with: <$report_session$>\<$value:host$>_2.jpg

    Find: name="pie chart 1"
    Replace with: name="host"

Version 3.2

    * Added new server checks.

    * Enhanced HTML Parsing.

    * Improved web form login detection.

    * Improved cookie handling.

    * Improved speed.

    * Minor improvements.

Version 3.1

    * Added new server checks.

    * Major database optimizations.

    * Added some more intelligence to report application security vulnerabilities.

    * Additional vulnerability details to reports (Recommendations and Affected Params for vulnerable applications).

    * Added ability to customize CGI dirs for the web server scan. This is available under Checks/Server Checks in the main
Sandcat Interface.

Sandcat 3



    * Improved speed.

    * Faster SmartUpdate.

    * Smaller setup.

    * Fixed small bug in displaying vulnerability description and recommendations for a few specific vulnerabilities in the
main Sandcat screen.

Version 3.09

    * New, improved manual.

Version 3.08

    * Added Time Left information in the Events screen.
    * Minor improvements.

Version 3.07

    * Added new server checks.
    * Denial-of-Service engine rewritten.
    * Added retry notification in the Sandcat Scanner tool.
    * Fixed minor bugs.

Version 3.06

    * Added new server checks.
    * Added option to export data in StickWiki page format.
    * Minor GUI changes.

Version 3.05

    * Added new server checks.

Version 3.04

    * Added new server checks.
    * Added CWE (Common Weakness Enumeration) support.
    * Added option to clear the StartURL list.
    * Log Analyzer executable renamed to "Logatool.exe".
    * Fixed rare issue while switching target type.
    * Fixed small issue in the Apache/PHP Hardener add-on.

Version 3.03

    * Added MX Injection checks.
    * Improved signatures.
    * Improved Install application.
    * Fixed minor bugs from 3.024 version.
    * Minor GUI changes and improvements.

Version 3.024

    * Added an option to send results by email from the session results screen.
    * Improved Uninstall application.
    * Minor GUI changes and improvements.

Version 3.023
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    * Added option to export data in XLS (Excel) format.
    * Improved PDF export.
    * Additional optimizations were made to speed up report generation.
    * Fixed minor bugs.
    * Minor GUI changes and improvements.

Version 3.022

    * Improved PDF export.

Version 3.021

    * Fixed minor bugs in generating PDF reports.

Version 3.02

    * A new add-on has been developed for configuring target settings.
    * Minor GUI changes and improvements.

Version 3.016

    * Major optimizations to speed up report generation.

Version 3.01

    * Sandcat is now able to exploit AJAX-based web applications.
    * Added an option to pause the scan if there is an excessive number of timeouts (see Options -> General -> Timeout
from the standards buttons toolbar). Sandcat will warn if there is excessive timeouts, show recommendations and pause
the scan if the option is enabled.
    * Added ability to enter host specific error page signatures. If you add a signature using the Request Viewer, it will now
be host specific, not a global setting that applies to all hosts. We've also added a tab in the Target Settings screen of the
Sandcat GUI that allows to see and edit these host specific signatures.
    * It is still possible to use the Advanced/Error Pages menu option to add/remove error page detection signatures, but
this

list will be a global setting (that applies to all websites).

    * Improved timeout and error handling.
    * Fixed log analyzer add-on.
    * Fixed minor interface problems with the Request Viewer.

Version 3.0

SESSION MANAGER

    * All new assessments will now have a specific name (session name). An add-on has been developed for managing
sessions.
    * Sandcat will prompt for a session name when an assessment starts.
    * There's an option that tells the scanner to never prompt for a session name (see Options -> General -> GUI
Preferences from the standard buttons toolbar). If this option is enabled, Sandcat will automatically choose a session
name based on the current date and time.
    * Sandcat instances can now have different settings. It is also possible to load settings from an external file or past
session, and to load the application's default settings (see File -> Settings from the menubar).
    * Default scan method changed to Complete (No DoS).
    * Added option to configure the default scan method (See Options -> Scan Settings from the menubar).
    * Added new, redesigned screens for managing options and checks.

REPORT DESIGN

    * It is now possible to edit report information, such as description, solution, and other info, before generating it. The
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Session Results screen also allows to include/exclude certain results and parts of the report and to edit user notes for
each report item.

    * Multiple report templates are now available, such as Standard, Complete and pass/fail reports. SANS Top 20,
OWASP PHP Top 5 and OWASP Top 20 compliance report options were added.
    * Sandcat now generates reports in HTML, PDF, XML, Text, RTF and DOC format. It is possible to edit the template for
all the available report methods, and to use custom templates.
    * Sandcat now exports data in CSV, Text, XML, INI and List file format. It is possible to export emails, HTML
comments, HTML forms, hidden form fields, links and other information.
    * Added option to insert a company logo (URL or file) in the report (see Report -> Settings -> General Options from the

standard buttons toolbar).

    * It is now possible to generate reports while the assessment is still being executed.
    * Added an option to filter results.
    * Command line support is available with the report generator (See the "Cmdline.txt" file for detailed information).
    * Most options related to the inclusion/exclusion of certain parts of the report were moved to the report generation
screen.
    * Removed "Store scan results and reports as XML files" option. This option has been replaced by the report generation
screen.

LOGGING

    * Added options to log suspicious responses and test errors for review (see Options -> Logging from the standard
buttons

toolbar). These new options are enabled by default.

    * Suspicious responses can be reviewed using the Request Viewer tool. During the review process, a suspicious
response

can be marked as a positive and then added as a new vulnerability to the report.

    * Logged packets are now associated with the current session ID.

APPLICATION CHECKS

    * Added new application checks: Email Form Hijacking, Hidden Price Form Field, and Unencrypted Login. These
checks can be

turned off if required (see Checks -> Application Checks from the standard buttons toolbar).

    * Added option to enter a start URL as target (see Target from the scan bar).
    * It is also possible to enter multiple Start URLs or to load a link list from an external file (see Target Settings from the
scan bar).
    * Added option to enter form authentication info. Sandcat will automatically detect login forms and use the login info to

log in (see Target Settings from the scan bar). Username and password fields, and additional form values can be
configured
(see Advanced -> Form Inputs from the menubar).

    * Added options to analyze robots.txt file and javascript (see Advanced -> Crawling Depth from the menubar).
    * Added "Distribute requests randomly" option (see Options -> Advanced Options from the standard buttons toolbar).
This option applies to the crawling process. If enabled, Sandcat will visit the found URLs in random order rather than
hierarchical order.
    * Added multithread functionality into the application scanner

module.

    * Sandcat can now retry a request if it fails (see Options -> Advanced Options from the standard buttons toolbar). The
default number of retries is 2.
    * Sandcat will now show the list of links found during an assessment. It is possible to export this list using the Session
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Results screen and use the list as start URLs in the next assessment.
    * Improved application checks: Comments in HTML.
    * Improved speed and stability.
    * Improved parsing.

DEPTH, FILTERS AND SIGNATURES

    * Added new options to edit the crawling depth: Maximum number of links per server, maximum links per page,
maximum URL length and maximum response size.
    * Added options to create user signatures for detecting application vulnerabilities (see Checks -> Application Checks ->

User Signatures from the standards button toolbar).

    * Added options to prevent logout and to relogin when needed (see Advanced -> Logout Pages from the menubar).
Logout pages

can be entered and signatures can be configured to check if a logout occurred.

    * Added option to search for suspicious strings in HTML comments. It is possible to enter a list of suspicious strings.

(see Advanced -> HTML Comments from the menubar).

    * Added option to enter a list of common form values (see Advanced -> Form Inputs from the menubar). Some internal
variables are available.
    * Added option to ignore common unnecessary URL/form parameters. Additional objects can now be specified to be
ignored during the testing process, such as a list of URL/form parameters, certain pages, folders or extensions (see
Advanced -> Ignore List from the menubar).
    * User error page detection signatures moved to Advanced -> Error Pages. It is now possible to specify regular
expressions.
    * Old signatures - It is necessary to re-enter error page signatures in this version. The old signatures will not be loaded.
You can manually import the old filters from the "Fpfilter" file in the root of the installation path of Sandcat.
    * Improved error page signatures.

SERVER CHECKS

    * Improved server checks: Denial-of-Service, Outdated Server Software.
    * Dramatically improved speed.
    * Improved stability.

OTHER CHANGES AND IMPROVEMENTS

    * Added option to enter custom header fields (see Options -> Scan Settings -> Misc Options from the standard buttons
toolbar).
    * Sandcat can now dynamically adjust the number of threads (see Options -> General from the standard buttons
toolbar). This option is enabled by default.
    * Added more information about scan methods.
    * Main executable renamed to "Sandcat.exe". It may be necessary to update your Windows shortcuts.
    * Improved automatic update feature. SmartUpdate will ask before closing any active modules.
    * Improved timeout and error handling.
    * Improved cookie handling.
    * Improved proxy support.
    * Improved HTTP-SSL support.
    * Improved GUI performance.

Updating the License Information

Your license info should be entered at the login screen (menu File/Log in option). Clicking "Connect" will save/update the
config.
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If you need to change the registrant's name and company, please email register@syhunt.com

You can also provide additional emails to receive the Sandcat newsletter.
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Support
Reporting Issues

Did you find an anomaly? Please notify us at bug@syhunt.com.

The following information may be useful to accelerate the review:

   1. What is the target server software (name and version)?
   2. What is your OS (name, version and edition) and hardware details?
   3. Did you experience this issue with other target servers?
   4. Screenshots and log (usually the latest log file in the Logs folder (name format is [date][time].log))
   5. Configuration files (all configuration files are located in the Config subfolder).
   6. Version number of the files Sandcat.exe, Srvcheck.exe and Secrobot.exe

Requesting Features

Do you have any thoughts on improving Sandcat?

What is your opinion about the recent product improvements?

We've been updating Sandcat on a regular basis with new features and improvements, and user comments are a main part
of the evolving process. Your feedback and suggestions are very welcome. You can always send us feature requests and
contact our tech staff directly at sandcatdev@syhunt.com
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What is Sandcat?
Sandcat is a remote web application security assessment scanner. It allows you to scan for the most common web
application flaws from a hacker's perspective. Sandcat will remotely inject data in the web applications and analyze the
application response in order to determine if the application code is vulnerable to specific attacks (such as SQL Injection,
XSS, and many other web application vulnerability flaws).

Which operating systems and applications are supported for scanning?
Sandcat modules are built with the flexibility to cover multiple web server platforms:

   1. Any web server platform (via remote scanning). Sandcat scans all types of web servers, such as Unix, Linux or NT.
   2. Devices such as routers and firewalls that run web sites.
   3. Tests intrusion detection systems.
   4. An assessment tool designed specifically for Apache and PHP platforms is also available. 

How many new vulnerabilities added last year (2007)?
More than 3000 new server checks. A complete list is available online at 
http://www.syhunt.com/index.php?section=resources.updates

Does Sandcat includes checks for vulnerabilities discovered by Syhunt?
Yes, recently we've discovered multiple vulnerabilities in a file sharing focused web server. The vendor was contacted and
these vulnerabilities were fixed. We then published an exploit demonstration tool and three advisories in our website, and
immediately included checks in Sandcat. This is our standard procedure when we discover vulnerabilities.

How often does Syhunt provide updates and how are they distributed?
Immediate to monthly, depending on the severity of new discovered vulnerabilities and the range of affected systems. We
do provide automatic (automatic update feature) or manual updates (manual downloading).

Scanner Checks

Sandcat scans for the vulnerabilities listed in the OWASP's Top Ten Most Critical Web Application Security
Vulnerabilities and the PHP Top 5 Vulnerabilities documents. It includes a fault-injection test module for that purpose
(scanning for vulnerabilities in custom-built web applications). The tool's database includes over 260 web application
security checks in over 38 categories of web attacks. We have been adding new attack variants on a regular basis.
Remote command execution, XSS (cross-site scripting), SQL injection, PHP configuration and filesystem attacks are
some of the most known types of vulnerabilities tested by Sandcat.

A complete list of checks performed by Sandcat is available at http://www.syhunt.com/index.php?section=sandcat.checks
.

A list of CVEs and OSVDB entries researched is also available at http://www.syhunt.com/index.php?section=sandcat.cve

We've been focusing our attention in databases, projects and standards from some of the organizations listed at:
http://www.syhunt.com/index.php?section=resources.links

Compliance

An overview document about the Sandcat Compliance features is available at 
http://www.syhunt.com/docs1/Sandcat_Compliance.pdf.

A complete list of the compliance checks is available at http://www.syhunt.com/index.php?section=sandcat.checks.

MX Injection Checks

We're proud to say that Sandcat is the first web application scanner to perform MX Injection checks. More than 20 variants
of MX Injection attacks are tested. For more information about MX Injection vulnerabilities, visit:
http://www.webappsec.org/projects/articles/121106.shtml

Installation
Download Information

Sandcat is available for download at: http://www.syhunt.com/index.php?section=sandcat.download

Sandcat Pro is available for download at: http://www.syhunt.com/index.php?section=members.home. Please note that
this version is only available for registered users.

System Requirements

Sandcat™

   1. 20 MB of memory
   2. 100 MB of free disk space
   3. Any Win32 platform (Windows 95, 98, ME, NT, 2000, 2003, XP or Vista)
   4. As a user of Windows 2000, 2003, XP or Vista you may need to be logged in with full administration rights
   5. Python (optional for running Sandcat Extensions written in Python language)

Sandcat™ Professional

   1. 20 MB of memory
   2. 100 MB of free disk space
   3. Internet connection (optional for remote scanning or performing automatic updates)
   4. Any Win32 platform (Windows 95, 98, ME, NT, 2000, 2003, XP or Vista)
   5. As a user of Windows 2000, 2003, XP or Vista you may need to be logged in with full administration rights
   6. Python (optional for running Sandcat Extensions written in Python language)

Wine

Sandcat 3.4 or later: Sandcat runs under WINE for Linux though it is not supported. The SmartUpdate feature specifically
will not work under WINE. Numerous changes have been made in Sandcat 3.5 and it doesn't run perfectly under WINE
unless when executed as individual modules. We will address this compatibility issue in the next releases

Personal Firewalls

If you use a personal firewall, you'll just have to let the firewall know that Sandcat is authorized to make connections to the
Internet. However, some software firewalls do not handle high loads very well. It is not recommended to run both a personal
firewall and Sandcat on the same machine.

Liability Disclaimer

This software should be used only by system administrators (or other people in charge). It should not be used to scan web
sites outside of your direct control.

The entire risk arising out of the use or performance of such products and documentation remains with you. In no event
shall Syhunt or its suppliers be liable for any damages whatsoever (including, without limitation, damages for loss of
business profits, business interruption, loss of business information, or other pecuniary loss) arising out of the use of or
inability to use the products or documentation, even if Syhunt has been advised of the possibility of such damages.
Because some states/ jurisdictions do not allow the exclusion or limitation of liability for consequential or incidental
damages, the above limitation may not apply to you.

Syhunt EULA

NOTICE -- READ ALL OF THE TERMS AND CONDITIONS OF THIS END USER LICENSE AGREEMENT BEFORE
DOWNLOADING, COPYING, INSTALLING OR USING THE SOFTWARE, CONTENT, DATA OR DOCUMENTATION
(EACH AS DEFINED BELOW).

INSTALLING AND/OR USING THE SOFTWARE, SERVICE, CONTENT, DATA AND DOCUMENTATION (COLLECTIVELY,
THE "PRODUCT") INDICATES YOUR ACCEPTANCE OF THESE TERMS AND CONDITIONS. IF YOU DO NOT ACCEPT
THESE TERMS AND CONDITIONS, YOU MUST DELETE ANY SOFTWARE, CONTENT AND DATA FROM YOUR
HARDWARE. PLEASE NOTE THAT YOU MAY NOT USE, COPY, MODIFY OR TRANSFER THE PRODUCT, OR ANY
COPY OR PORTION THEREOF, EXCEPT AS EXPRESSLY PROVIDED IN THIS LICENSE AGREEMENT.

IMPORTANT -- READ CAREFULLY: By clicking on the "Yes" or other appropriate assent button to make and use copies
of the Syhunt Vulnerability Assessment Software (the "Software"), access the Syhunt Vulnerability Assessment service
via any computer (the "Service") and to use the vulnerability data (the "Data") and other content accessed therewith (the
"Content"), you ("Licensee") agree to be and are hereby bound by the terms and conditions of this License Agreement
(this "Agreement"). If applicable, Licensee must also agree to certain terms and conditions relating to Licensee's
subscription to the Software, Service, Content and Data, as may be required by third-parties processing any fees on behalf
of Syhunt (the "Third Party Subscription Terms"). If Licensee does not agree to the terms and conditions of this Agreement
(and the Third Party Subscription Terms, if applicable), Licensee should not download, copy, install or use the Product and
must promptly destroy any and all copies of the Software, Service, Content, Data and any accompanying documentation
("Documentation") made by Licensee.

I. SYHUNT'S SUBSCRIPTION TERMS. For purposes of this Agreement, the "Syhunt Site" shall mean the web site
currently located at www.syhunt.com.

A. For Trial Subscriptions. Syhunt does not charge a subscription fee for Licensee's trial use of the Product. Licensee
shall however be subject to the terms and conditions of this Agreement and Licensee's use of the Product during the
applicable trial period may be terminated by Syhunt in the event Licensee breaches any term of this Agreement.

At the end of the applicable trial period, Licensee shall have the option of subscribing to the Syhunt Vulnerability
Assessment Professional Product by visiting www.shareit.com or the Syhunt Site and providing relevant payment
information. In the event Licensee does not purchase a subscription at the end of the applicable trial period, either (a) the
Syhunt Vulnerability Assessment Professional Product will be disabled and Licensee will instead be provided with the
Syhunt Vulnerability Assessment Free Product, which Licensee will have the right to use subject to the terms below, if
Licensee had a trial subscription of the Product, or (b) the Product will be disabled in its entirety if Licensee had a trial
subscription of the Product.

B. For Syhunt Free Subscriptions. Syhunt does not charge a subscription fee for Licensee's use of the Syhunt
Vulnerability Assessment Free Product, which offers limited content and functionality. Licensee's use of Syhunt Free shall
subject to the terms and conditions of this Agreement.

C. For Annual Syhunt Vulnerability Assessment Professional Subscriptions. To subscribe to the Syhunt Vulnerability
Assessment Professional Product from the website currently located at www.shareit.com (the "Share-it Site"), Licensee
agrees to pay Syhunt's payment processing partner, Share-it, Inc. ("Share-it"), the applicable annual subscription fee listed
on the Share-it Site, any applicable taxes and any other charges incurred on Licensee's user name and password.
Subscription fees will be billed by Share-it to Licensee at the beginning of Licensee's subscription. Syhunt reserves the
right to increase its subscription fee or institute new fees at any time, upon reasonable notice posted in advance on the
Share-it Site. Licensee shall not be charged retroactively for any such increased or new fees but shall be billed the
applicable increased or new fee upon renewal, if any.

1. Money Back Guarantee. All fees are non-refundable except as otherwise set forth in this Agreement.

2. Renewal. If Licensee desires to renew Licensee's subscription to the Syhunt Vulnerability Assessment Professional
Product, Licensee must visit either www.shareit.com or the Syhunt Site and provide relevant payment information. Share-it
will not automatically charge Licensee for renewals. Syhunt will use reasonable efforts to send a reminder prior to the end
of Licensee's current subscription period to the e-mail address Licensee provided in connection with Licensee's registration
on the Share-it Site.

D. Other Charges. In addition to the subscription fees and obligations set forth in Sections A through C above, Licensee is
responsible for all charges associated with connecting to the Syhunt Site, including all telephone line access, telephone

and computer equipment and any related service fees.

II. GRANT OF LICENSE.

Syhunt Informática, Ltda. ("Syhunt") hereby grants to Licensee a non-exclusive license to use the Software, Service,
Content, Data and Documentation subject to the following terms:

Licensee may: (a) install the Software on one computer and use the Software, Content and Data for personal,
non-commercial purposes only; (b) access the Service via one computer; (c) view the Content and the Data in connection
with the Software and/or Service on the screen of such computer; (d) save the Content and the Data on such computer,
provided that Licensee does not remove any copyright notices that appear in connection therewith and does not modify the
Content or the Data in any way; and (e) make one copy of the Software, Content and Data for back-up, archival purposes,
provided such copy contains all of the original proprietary notices provided with or otherwise relating to such Software,
Content and Data. Notwithstanding anything in this paragraph, Licensee may transfer the Software from one computer to
another computer in connection with Licensee's use of the Product, provided that (i) Licensee deletes all copies of the
Software from the first device, and (ii) Licensee may use the Product on only one computer at a time.

Licensee may not use, or permit other individuals or entities to use, the Software, Service, Content, Data or
Documentation except under the terms expressly listed above. Without limiting the foregoing sentence, Licensee shall not,
and shall not permit any other individual or entity to: (a) use the Software, Service, or Data for service bureau, time-sharing
or other similar purposes; (b) use the Product following expiration or termination of the applicable subscription period; (c)
modify, translate, reverse engineer, decompile, disassemble (except to the extent that this restriction is expressly
prohibited by law) or create derivative works based upon the Software, Service, Content, Data or Documentation; (d) copy
the Software, Service, Content, Data or Documentation (except as permitted above); (e) rent, lease, sell, offer to sell,
distribute, or otherwise transfer rights to the Software, Service, Content, Data or Documentation; and (f) remove any
proprietary notices or labels on or relating to the Software, Service, Content, Data or Documentation. Licensee
acknowledges that Syhunt has the right to remove listings, restrict access, terminate and otherwise modify the services
provided by Syhunt from the Syhunt Site for any reason, including but not limited to a breach of any of the Terms of
Service agreement set forth on the Syhunt Site (the "Terms of Service Agreement"), or the Third Party Subscription Terms
if applicable.

III. ENHANCEMENTS AND UPDATES.

This license does not grant Licensee any right to any enhancement or update of the Software, Service, Content, Data and
Documentation.

IV. TITLE.

All right, title and interest in and to the Software, Service, Content, Data and Documentation (including without limitation all
intellectual property rights) shall remain in Syhunt and/or its suppliers and licensors. Without limiting the foregoing: (a) the
Software, Service, Content, Data and Documentation are protected by copyright laws and international copyright treaties;
and (b) the Content (including the content contained in the Software media demonstration files) and Data, and all rights
thereto, are the property of the applicable content owner and are protected by applicable copyright or other law. This
license gives Licensee no rights to such Content or Data.

The following copyright notices apply to, and shall not be removed from, the Software and the Documentation and certain
Content available in connection therewith:

©2005 Syhunt Informatica Ltda. All rights reserved.

V. DISCLAIMERS.

THE SOFTWARE, SERVICE, CONTENT, DATA AND DOCUMENTATION ARE PROVIDED "AS IS" AND WITHOUT
WARRANTY OF ANY KIND. TO THE MAXIMUM EXTENT PERMITTED BY APPLICABLE LAW, SYHUNT AND ITS
LICENSORS AND SUPPLIERS FURTHER DISCLAIM ALL WARRANTIES OF ANY KIND (WHETHER EXPRESS OR
IMPLIED, ARISING BY LAW OR OTHERWISE), INCLUDING WITHOUT LIMITATION ANY WARRANTIES OF
PERFORMANCE, MERCHANTABILITY AND NONINFRINGEMENT. SYHUNT AND ITS LICENSORS AND SUPPLIERS
ALSO DISCLAIM ALL WARRANTIES OF QUALITY, ACCURACY, COMPLETENESS, EFFECTIVENESS, RELIABILITY,
FITNESS FOR A PARTICULAR PURPOSE, USEFULNESS, USE OR RESULTS TO BE OBTAINED FROM THE
CONTENT OR THE DATA, OR THAT THE CONTENT OR THE DATA WILL BE ERROR-FREE. TO THE EXTENT
ALLOWED BY APPLICABLE LAW, ANY IMPLIED WARRANTIES THAT CANNOT BE DISCLAIMED ARE LIMITED TO
NINETY (90) DAYS FROM THE DATE OF INITIAL DOWNLOAD OR INSTALLATION OF THE SOFTWARE, CONTENT

AND/OR DATA OR ACCESS OF THE SERVICE BY OR ON BEHALF OF LICENSEE. THE ENTIRE RISK ARISING OUT
OF THE USE OR PERFORMANCE OF THE SERVICE, SOFTWARE, CONTENT, DATA AND DOCUMENTATION
REMAINS WITH LICENSEE.

WITHOUT LIMITING THE GENERALITY OF THE FOREGOING, LICENSEE ACKNOWLEDGES THAT THE DATA MAY
INCLUDE INACCURACIES AND THAT LICENSEE WILL USE COMMON SENSE AND FOLLOW STANDARD SECURITY
PRECAUTIONS IN CONNECTION WITH LICENSEE'S USE OF ANY VULNERABILITY ASSESSMENT RESULTS
GENERATED BY THE SOFTWARE OR THE SERVICE.

VI. WAIVER OF DAMAGES.

TO THE MAXIMUM EXTENT PERMITTED BY APPLICABLE LAW, IN NO EVENT SHALL SYHUNT OR ITS SUPPLIERS
OR LICENSORS BE LIABLE TO LICENSEE OR ANY THIRD PARTY FOR: (A) ANY CLAIM, DEMAND OR ACTION
(IRRESPECTIVE OF THE NATURE OR THE CAUSE OF THE CLAIM, DEMAND OR ACTION) ALLEGING ANY LOSS,
INJURY OR DAMAGES ARISING OUT OF THIS AGREEMENT OR WHICH MAY RESULT FROM THE USE OR
POSSESSION OF THE PRODUCT; (B) ANY LOSS OF PROFIT, REVENUE, CONTRACTS OR SAVINGS, OR ANY
OTHER INDIRECT, INCIDENTAL, SPECIAL, PUNITIVE OR CONSEQUENTIAL DAMAGES ARISING OUT OF
LICENSEE'S USE OF OR INABILITY TO USE THE PRODUCT, ANY DEFECT IN THE PRODUCT, OR THE BREACH OF
THESE TERMS OR CONDITIONS, IN EACH CASE, WHETHER IN AN ACTION IN CONTRACT OR TORT OR BASED ON
A WARRANTY, EVEN IF SYHUNT OR ITS SUPPLIERS OR LICENSORS HAVE BEEN ADVISED OF THE POSSIBILITY
OF SUCH DAMAGES.

VII. LIMITATION OF LIABILITY.

THE TOTAL LIABILITY OF SYHUNT AND ITS SUPPLIERS AND LICENSORS ARISING OUT OF OR IN ANY WAY
RELATED TO THIS AGREEMENT OR ITS IMPLEMENTATION SHALL NOT EXCEED THE AMOUNTS PAID BY
LICENSEE TO SYHUNT UNDER THIS AGREEMENT AND/OR THE THIRD PARTY SUBSCRIPTION TERMS, IF
APPLICABLE. BECAUSE SOME STATES/JURISDICTIONS DO NOT ALLOW THE EXCLUSION OR LIMITATION OF
LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES, THE ABOVE LIMITATION MAY NOT APPLY TO
LICENSEE.

VIII. DISCLAIMER OF ENDORSEMENT.

Reference to any products, services, processes, hypertext links to third parties or other information (by trade name,
trademark, manufacturer, supplier or otherwise) does not necessarily constitute or imply its endorsement, sponsorship or
recommendation by Syhunt or its suppliers or licensors. Product and service information are the sole responsibility of each
individual vendor. The Syhunt Informatica Ltda name and logo, and other trademarks and trade names owned by Syhunt,
may not be used in any commercial manner without the prior written consent of Syhunt.

IX. TERMINATION.

This Agreement shall terminate automatically if Licensee fails to comply with any of the terms and conditions described in
this Agreement. No notice shall be required from Syhunt to effectuate such termination. On termination, Licensee must
destroy all copies of the Software, Service, Content, Data and Documentation. Without limiting the foregoing, Syhunt may
terminate this Agreement immediately for any breach by Licensee of the Terms of Service Agreement, or the Third Party
Subscription Terms if applicable. In the event of any termination by Syhunt pursuant to this Section IX, Licensee shall not
be entitled to any refund of pre-paid subscription fees.

X. INDEMNITY.

Licensee agree to indemnify, defend and hold Syhunt and its parents, subsidiaries, affiliates, suppliers and licensors
(including their respective licensors, suppliers, assignees, subsidiaries, affiliated companies, and the respective officers,
directors, employees, shareholders, agents and representatives of each of them) free and harmless from and against any
liability, loss, injury (including injuries resulting in death), demand, action, cost, expense, or claim of any kind or character,
including but not limited to attorney's fees, arising out of or in connection with any use or possession by Licensee of the
Product.

XI. TERMS OF SERVICE AGREEMENT.

The Terms of Service Agreement is incorporated herein by reference, provided, however, that in the event of any conflict
between the terms and conditions of this Agreement and the terms and conditions of the Terms of Service Agreement, the
terms and conditions of this Agreement shall govern.

XII. GOVERNING LAW.

The rights and obligations of the parties under this Agreement shall be governed and construed under the laws of the State
of Rio de Janeiro, Brazil, without reference to its conflict of laws principles.

XIII. ENTIRE AGREEMENT.

This Agreement constitutes the complete and exclusive agreement between Syhunt and Licensee with respect to the
subject matter hereof and supersedes all prior oral or written understandings, communications or agreements not
specifically incorporated herein. This Agreement may not be modified except when executed by an authorized
representative of Syhunt and Licensee.

XIV. WAIVER.

The failure of either party to require performance by the other party of any provision hereof shall not affect the full right to
require such performance at any time thereafter, nor shall the waiver by either party of a breach of any provision hereof be
taken or held to be a waiver of such or any other provision.

XV. ASSIGNMENT.

Neither this Agreement nor any rights or obligations of Licensee hereunder may be assigned by Licensee, in whole or in
part, without the prior written approval of Syhunt. Any assignment in derogation of the foregoing shall be null and void.

XVI. SEVERABILITY.

If any part of this Agreement is for any reason found to be unenforceable, all other parts nevertheless remain enforceable
as long as a party's rights under this Agreement are not materially affected. In lieu of the unenforceable provision, the
parties will substitute or add as part of this Agreement a provision that will be as similar as possible in economic and
business objectives as was intended by the unenforceable provision.

Basic QuickStart
Starting a scan

The Start button in the scan bar starts a scan. Before starting a scan, you must define targets (see below).

If your connection requires the use of a proxy server, you should visit File|Tools|Network Settings.

Defining targets

Click the Target button in the scan bar and select one of the following options:

Host(s) - You can enter a single host or multiple hosts separated by commas. Example: www.host1.com,www.host2.com.

Start URL - You can enter a full URL. Example: http://www.syhunt.com/search.php. If you want to add more than one
start URL, see the Start URLs topic.

Load from file - Allows you to load a list of hosts from a file on your disk.

IP Address - Allows you to enter a numeric IP Address. Depending on the server configuration, you may need to configure
a custom virtual host if you use this option (click the Target Settings button).

IP Range - Allows you to enter a IP Range. You may not be able to configure custom virtual hosts if you use this option
instead of the normal options.

If your target requires the use of host authentication, you can configure it by clicking the Target Settings button.

Additionally, you may want to define target ports (see below).

Defining target ports

The Port(s) field in the scan bar allows you to define target ports. You can enter a single port or multiple ports separated
by commas. Example: 80,443.

If you enter, for eg, "www.syhunt.com,www.syhunt.com.br" in the hosts field and "80,443" in the ports field, Sandcat will
scan these two ports on syhunt.com and syhunt.com.br and combine results into a single report.

Choosing a scan method

The Common Web Server Scan is the default scan method. The scanner will scan for outdated server software, and
common web server vulnerabilities and exposures. If you want to use a different scan method, click the Scan Method
button in the standard toolbar. You will be able to select one of the following options:

Common Web Server Scan - Scans for outdated server software, common web server vulnerabilities and more.

SANS Top 20 - Scans specifically for the SANS Top Twenty List of Critical Network Vulnerabilities.

Web Application Scan - Identifies flaws in custom web applications. This includes fault injection vulnerabilities such as
XSS, SQL Injection, File Inclusion, and more.

OWASP PHP Top 5 - Scans specifically for the OWASP Top Five List of PHP Vulnerabilities.

Fault Injection - Scans specifically for fault injection vulnerabilities. If this scan method is selected, all other checks that
does not require injection are disabled and Sandcat will then specifically check for SQL injection, XSS, file inclusion, and
similar flaws.

Complete Scan - Scans for both common web server vulnerabilities and web application vulnerabilities. This is the
combination of the common web server scan and the web application scan methods plus some additional checks. A
Complete Scan can sometimes be very time-consuming when performed against a web server that has a large quantity of
web folders (eg: 200 or more web folders).

Complete Scan (No DoS) - Same as before, but with denial-of-service tests disabled.

Note: Sandcat's web application scan is only activated when one of these scan methods are selected: Web Application
Scan, PHP Top 5, Fault Injection, SQL Injection, XSS or Complete Scan. All other scan methods does not include
application checks/spidering. 

Configuring SSL

If you want to configure SSL, click the SSL button in the scan bar. The following options will be available:

Auto - If this option is enabled, the scanner will automatically choose when to use SSL during the current session.

Enable - If this option is enabled, the scanner will always choose to use SSL.

Disable - If this option is enabled, the scanner will not use SSL.

Configuring additional options

The Options button in the standard toolbar gives you access to general and advanced options (see the Options topic for
more information on the available options). The default options are usually safe enough to accept.

Customizing the report

If you want to customize the report, click the Report button in the standard toolbar. The following options will be available:

Quick Notes - Allows you to add notes to the scan report.

Settings|General Options - Allows you to configure a custom report title, font, and more.

Settings|Colors - Allows you to customize report colors.

Settings|References - Lets you set which references should be included in the report. By default, CVE, BugTraq, and
OSVDB references are enabled.

Customizing checks

If you want to customize checks, click the Checks button in the standard toolbar. The following options will be available:

Application Checks - Allows you to configure which application tests should be performed. The list includes Common
Files, Extension Checking, Path Disclosure, Source Code Disclosure, and more.

Application Checks|Fault Injection - Allows you to configure which fault injection tests should be performed. The list
include Command Execution, Cross Site Scripting, Directory Listing, and more.

Server Checks - Allows you to configure which server checks should be performed. The list include ASP, CGI,
ColdFusion, Domino, FrontPage, IIS, and more.

Monitoring a scan

Click the Events button in the standard buttons toolbar to see the Events screen. This screen displays information related
to the current scan session (scan progress, found vulnerabilities, and more).

Aborting a scan

The Stop button will stop a scan in progress. This button will be grayed if you have not started a scan.

Generating a report

The Generate a Report button in the File menu allows you to generate reports. This will not be possible if you have not
started a scan. For detailed information about reports, see the Generating Reports topic.

Note: This feature is not available if you are running the free version of Sandcat.

Options

General

Enable autoupdate - Automatically updates the software. An Internet connection is required.

Enable program sounds - If this option is enabled, the scanner will play a sound when a vulnerability is found.

Use virtual hosts - Only disable this option if your site does not rely on virtual hosts or if you configured a custom virtual
host in the Target Settings screen for the target host. 

Use browser behaviour - When analyzing web sites there are numerous situations on which it is better to behave like a
web browser and less like a robot. This will often increase the Sandcat's accuracy.

User-Agent - Allows you to configure a custom user-agent. By default, the scanner will identify itself as Mozilla.

Scan Settings

Perform reconnaisance - Enables Sandcat to choose the exploits according to the type of web server you are testing,
reducing the assessment time.

Use fast CGI scanning method and Use the maximum optimization level - If these options are enabled, Sandcat will
constantly try to reduce the assessment time during the scan by optimizing checks. Both options have no impact in the
applications scan stage, only in the server scan stage.

TIMEOUT

Pause the scan if there is excessive timeouts - Sandcat will warn if there is excessive timeouts, show
recommendations and pause the scan if this option is enabled.

Filters

Filter invalid server responses, Use intelligent filtering and Use anti-redirect filtering - These options have been
developed for minimizing false positives and will never limit the depth of the analysis. If you disabled them you may get a
few false positives, specially during the server scan stage.

IGNORE LIST

Ignore common unnecessary URL/form parameters and Ignore common unnecessary extensions - These options
have been mainly developed for speeding up scans and increase the accuracy of the fault-injection checks. Disabling
these options may cause issues while performing crawling and application checks. Both options have no impact in the
server scan stage, only in the application scan stage.

Generating Reports
Sandcat Reports

Sandcat allows to edit the report information before saving or emailing them. You can generate reports multiple times using
data stored from current and past sessions. It is possible to use different templates, export data, select the information
that should be added, add notes, and if required you can develop your own templates and data exporting formats.

Previously generated reports can be viewed and managed using the Report Manager tool (see View|Reports).

Data from past sessions can be managed using the Session Manager tool (see View|Sessions). This is the tool
responsible for generating reports.

Generating Reports

To load a past session, you should use the Session Manager tool (see View|Sessions).

Double-click a session name to load the session information and you will be able to generate reports for the session you
selected. After clicking "Generate a Report", and selecting the output format, you can choose a place to save the report.

It is also possible to drop items from a report. By changing the Include option to "no", the item will not be included in the
report. You should perform this action before generating a report.

Automatically Emailing Reports

Sandcat can be configured to automatically email reports after a scan is completed. Multiple recipients can be entered,
and it is also possible to configure different mail addresses for each host if required. In order to achieve this:

1. Configure the email settings (see Tools|Email Options)

2. If you want to configure specific mail address for a host, click the Target Settings button in the scan toolbar and go to
the Email Alert tab.

3. Do not forget to enable the email alert feature (to do this click the Options button in the standard buttons toolbar, and
enable the "Automatically email scan results" option in the Reporting screen)

Using the Report Manager

Viewing a report

Double-click the report to open it. The report will open it in your default browser.

Copying a report

To copy a specific report to a folder, select the report and click the Copy To option.

Deleting a report

To delete a specific report, select the report and click the Delete option.

Deleting all reports

If you want to delete all reports, select Tools|Clear Report Data.

Sandcat Extensions and Theme Support
Sandcat Extensions

Sandcat Extensions are available via packages with .scx (SandCat EXtension) extension, which should be copied to the
Apps subfolder. Menu Tools/Extensions displays all available extensions and allows to configure them.

Before running Sandcat it is necessary to install Python 2.5 (or the latest available version) or most extensions will not be
available. The Update Checker extension, for eg, will not work if a Python installation is not found.

Python is free and can be downloaded from:
http://www.python.org/download/

Note: Extensions support can be disabled (see Options -> General)

Sandcat Theme Support

Sandcat Themes are available via packages with .thm extension, which should be copied to the Themes subfolder.

Menu Tools/Themes displays all available themes and allows to switch between themes.

Note: Theme support can be disabled (see Options -> General -> GUI Preferences)

Info for Contributors

With the release of Sandcat 3.5, Contributors can now take part in the evolution of Sandcat in the GUI front. 

The first preview of the Sandcat Development Kit is already available for download.

The Sandcat DevKit includes:
- An overview of the GUI and Extension Technologies
- The Sandcat GUI Source
- Extensions Examples
- Details on how to create an extension manifest file and more

Note: Currently only Sandcat Premium users and partners have access to this preview.

Sandcat GUI Source

All files used to define the Sandcat GUI can be found in the SandcatUI subfolder of the Sandcat DevKit.

Most files are HTML or images. Files with .opt extension define the options available in the Options and Checks screens.

Extensions Examples

We've created four extensions for Sandcat which we expect to serve as the basis for the development of new extensions
and
suggestions that will allow us to enhance the Sandcat extension system:

Update Checker - Checks for updates during startup

DoS Warning - Warns when the Denial-of-Service check is enabled and allows to disable it from the home

Emails - Displays a list of emails found by Sandcat in the current scanned host

Links - Displays a list of links found by Sandcat in the current scanned host

The source code of these extensions is available in the Extensions subfolder of the Sandcat DevKit.

Extension Configuration Screen

Configuration screens for extensions can be easily generated using the same format that the Sandcat GUI uses (the
Updcheck extension includes an example of this, more specifically the Updcheck.opt file).

Syhunt Packer

The Syhunt Packer application (responsible for generating SCX and THM files) can be found in the Sypacker subfolder of
the Sandcat DevKit. 

Usage examples:

Sypacker *.* [extensionname].scx
Sypacker *.* [themename].thm

FAQs

Why call it "Extensions" and not "Plugins"?
Plugins are often slightly different from extensions. We think that our system fits more in the category of extensions rather
than plugins. Sandcat Extensions can add new features to the Sandcat application. Each extension usually consists of a
single file with SCX extension. SCX stands for SandCat eXtension.

The previous Sandcat versions included a plugin system in beta stage. Is this the current Sandcat Extensions
Platform that evolved?

Not exactly. The plugin system included in the previous Sandcat versions was specifically for developing open exploits.
Our goal was to develop a simpler open plugin system for developing HTTP exploits. However the number of new server
and application vulnerabilities disclosed every month is so big that even advanced Sandcat users prefer us to handle the
exploits development and research.

Is the Sandcat Extension system mature?
The Sandcat Extensions Platform is still under development. We expect it to become more advanced over time.

What language can be used for developing a SCX?
Python language is used for extensions development. Some knowledge of HTML and CSS (Cascading Style Sheets) is
also required.

Contact

Questions, comments, suggestions, or contributions are all welcome and can be sent via email to:
sandcatdev@syhunt.com

Info on Specific Features
Command Line Support

Sandcat's main executables are "Sandcat.exe" (GUI), "Srvcheck.exe" (server scanner) and "Secrobot.exe" (application
scanner), the last one responsible for the execution of the application checks. Below you will find detailed info about the
supported commands.

Sandcat Server Scanner

Any or all of the following parameters may be passed via command-line.

Srvcheck.exe [Target] [Port] [Parameters]

Sample 1 (Single Host Scan):

Srvcheck.exe 127.0.0.1 80 -h -sr:normal -start

Sample 2 (IP Range Scan):

Srvcheck.exe 127.0.0.1-15 80 -r

Supported command-line parameters are:

-h => Single Host Scan
-r => IP Range Scan
-sr:normal => Normal Scan
-sr:complete => Complete Scan
-sr:cmpnodos => Complete Scan (No DoS)
-sr:top20 => SANS Top 20 Scan
-start => Automatically perform scan
-close => Automatically close after running
-xml => Enable XML reports
-ssl => Enable SSL
-sl:1 => Scanning Level 1 (High Performance)
-sl:2 => Scanning Level 2 (Medium Performance)
-sl:3 => Scanning Level 3 (Low Performance)
-nosnd => Disable warning sound
-vhosts => Use virtual hosts
-nocache => Make no-cache requests
-malert => Use MailAlert
-evadids => Evade IDS
-nodos => Disable DoS Tests
-eslow => Enable the slowdown mechanism
-igne => Automatically ignore errors

Sandcat Application Scanner

Any or all of the following parameters may be passed via command-line.

Secrobot.exe [Target] [Port] [Parameters]

Supported command-line parameters are:

-url:[url] => Start URL (eg. index.php, if not used ""
will be assigned)
-start => Automatically perform scan
-close => Automatically close after running
-sr:normal => Normal Scan
-sr:complete => Complete Scan

-sr:faultinj => Fault Injection
-sr:sqlinj => SQL Injection
-sr:xss => XSS (Cross-Site Scripting)
-sr:phptop5 => OWASP PHP Top 5 Scan
-xml => Enable XML reports
-ssl => Enable SSL
-nodos => Disable DoS Tests
-eslow => Enable the slowdown mechanism
-igne => Automatically ignore errors

Sandcat Log Analysis Tool

Any or all of the following parameters may be passed via
command-line. Results are saved to the Logs folder.

Logcheck.exe [Web Server Log] [Parameters]

Supported command-line parameters are:

-start => Automatically perform scan
-close => Automatically close after running
-sl:1 => Scanning Level 1 (High Performance)
-sl:2 => Scanning Level 2 (Medium Performance)
-sl:3 => Scanning Level 3 (Low Performance)
-nores => Disable IP to Name Resolution

Sandcat Report Editor (Codename Hermes)

Any or all of the following parameters may be passed via command-line.

Note: Sandcat will not interact with Hermes if executed as individual modules. Reports will be instead automatically saved
in the root of the "Rep"and "Spd" folders. This is a limitation, which will probably be removed in future versions. You can
use parameters -start and -close to automatically start the scan and close the software after the scan is completed, and
you can also specify the -malert parameter if you want to automatically email the reports in the end of the assessment (a
copy of the report will then also be available in the "Sent" folder).

Hermes.exe [Session Name] [Report Type] [Parameters]

Sample 1 (Editing Report Data):
Hermes.exe 10-17-2006_04.08.09

Sample 2 (Generating a Report):
Hermes.exe 10-17-2006_04.08.09 Standard -genreport

Sample 3 (Generating and Emailing a Report):
Hermes.exe 10-17-2006_04.08.09 -genreport -email

Supported command-line parameters are:

-genreport => Automatically generate report
-email => Automatically email the report
-close => Automatically close after running

Scan Methods

Common Web Server Scan: Srvcheck.exe + -sr:complete
SANS Top 20: Srvcheck.exe + -sr:top20
Web Application Scan: Secrobot.exe + -sr:complete
Fault Injection: Secrobot.exe + -sr:faultinj
Complete Scan: Srvcheck.exe + sr:complete -and- Secrobot.exe + -sr:complete
Complete Scan (No DoS): Srvcheck.exe + sr:complete + -nodos -and- Secrobot.exe + -sr:complete -nodos

SSL Support

SSL support in the Sandcat scanner relies on two Dynamic Link Library (DLL) files, SSLeay32.DLL and libeay32.DLL,
developed by the OpenSSL Project. When these two DLL files are present then SSL support is available, which means
that you can scan secure sites with "https" addresses.

When these two DLL files are not present you cannot use SSL to securely access "https" addresses. You can still scan
regular "http" addresses.

OpenSSL Installation

The OpenSLL DLL files Ssleay32.dll and Libeay32.dll do not require any special installation procedure. They just need to
be present in order to be automaticaly utilized by the scanner.

The standard Syhunt Sandcat Setup kit copies the OpenSSL DLLs Ssleay32.dll and Libeay32.dll to the installation
directory. The
standard ZIP distribution includes these files. But they are strictly optional.

The OpenSSL DLL files are not necessary for the normal functioning of the Syhunt Sandcat scanner. If the OpenSSL DLL
files are not present, the scanner still operates normally but without SSL support.

The scanner automatically detects and adjusts to the presence or absence of the OpenSSL DLLs. You can also manually
select the SSL support style via the "SSL" option in the scanner toolbar.

Alternative SSL Support

If for any reason you don't want to use the built-in SSL feature, you can use the stunnel (http://www.stunnel.org/) tool as a
replacement.

Both stunnel and the Sandcat's built-in SSL feature rely on SSLeay

Using Client Certificates

Fill in the target and click the Target Settings button (the Target Settings button is in the left of the green arrow button).
The Certificates tab allows you to configure the client certificates.

Login Credentials

You can configure login credentials in the Target Settings screen (Authentication tab). This option is available via the
toolbar, after the SSL button. It is necessary to enter a target host (or hosts) before accessing it.

Scan Methods

There are different scan methods that can be chosen in Sandcat and it is possible to customize scan settings for each
target host. See Basic QuickStart for detailed information on this.

Configuring Start URLs

If you need to scan links that are not referenced in any page, here is the procedure:

1. Enter the host name or IP address in the hosts field.

2. Click the Target Settings button in the toolbar.

3. Use the Start URLs tab to add the unreferenced URLs.

Sandcat will always start from the root (unless you have configured a specific directory). The Miscellaneous tab allows you
to configure a specific directory (using the Virtual Directory field).

Target Definition

Sandcat allows to manually enter hosts, IP address, IP range or load the list of hosts from an external list file. See Basic
QuickStart for detailed information on this.

The Sandcat Folders

Apps - Sandcat Extensions
Config - Sandcat User Configuration
Hosts - Temporary scan data
Lang - Language files
Logs - Packet and log files
Sent - Emailed scan results
Snd - Sound files
Spd - Mining/spidering scan results
Rep - Reports and session-related data
Temp_upd - Temporary SmartUpdate files
Themes - Sandcat Themes

Custom User Files

Config/Logfmt - Custom log format files for the Log Analysis Tool.
Config/Templates - Custom templates (for generating reports or exporting scan data).
Exploits - This folder is now reserved for custom server checks (checks created by the user)

Obsolete Folders

There are numerous files and folders (some listed below) that have no use anymore with the new Sandcat version. Run
Cleanup.bat (located in the root of the Sandcat installation) to remove them.

Conf - Log file format files used by the Log Analysis tool.
Db - This folder is reserved for custom server checks (checks created by the user)
Himgs - Images used by the Hermes (Report Editor) module.
Plc - Report/Data export templates and main configuration file
Plugins - This folder is reserved for plugins (beta feature)

Virtual Directory in Sandcat

The Sandcat server checks will be executed in the root folder unless the Virtual Directory option is configured. The virtual
directory option allows the scanner to focus all its attention on a specific directory (eg, /~syhunt).

To set a virtual directory, you must first enter a target host in the address field. Click Target Settings button and you will
get access to a new screen. The virtual directory field is located in the Miscellaneous tab.

Web Form Login

If your web site requires authentication prior to allowing access to all or most of the website contents, then the success of
the authentication stage is absolutely crucial. If it fails, for eg, during a Complete Scan, many checks will still be
performed (during the server checks stage), but the application checks, which is the second and most important part of the
scan, will not be performed. 

Sandcat can detect most form logins, but some of them may not be automatically recognized if they have unusual
characteristics. If you ever face this problem, you can teach Sandcat to log into the application.

Let's suppose you are having an issue with Sandcat with the following web form login:

<div class="InputLine"><input name="UserBox" id="UserBox" type="text" class="InputBox"/>User Name</div>
<div class="InputLine"><input name="PasswordBox" id="PasswordBox" type="password" class="InputBox"
>Password<div>

The following procedure will reprogram Sandcat to recognize the form login:

1) Enter the username and password in the "Authentication (Form)" tab in the Target Settings screen (see the screenshot
below). If you have already made this, go to step 2.

2) Now go to menu Advanced in the main Sandcat screen menu and select the "Form Inputs" menu option. Double-click
"List of common form values" and add the following values:

UserBox=@sandcat_web_form_username
--and--
PasswordBox=@sandcat_web_form_password

Values after "=" are internal variables, this ensures that the web form login information entered in the target settings screen
is used in the two form inputs specified (UserBox and PasswordBox).

Sandcat is now ready to detect this form login.

Bypassing Login Pages

There's also an alternate way to bypass the login page. You have to log into the application using your web browser, and
copy the cookie after logging in (you can do this using for eg, the Firefox's Add N Edit Cookies add-on (
http://addneditcookies.mozdev.org/), or a packet sniffer (such as the freeware Wireshark - http://www.wireshark.org/) if it is
not HTTPs connection). Open the target settings screen and go to the last tab (Miscellaneous) and paste the cookie in the
"Custom cookie" field.

Preventing Logout

Sandcat can also detect most logout pages, but this can fail sometimes if the logout page does not match common
patterns. Add the logout page URL to your current config (see menu Advanced|Logout Pages). This will prevent Sandcat
from accidentally logging out. 

Request and Response Logging
Sandcat packets are saved in the Logs/[session name] subfolder using the .pkt extension. You can see the packet logs
using the Request Viewer utility (see View|Requests). If you open these files using Notepad, or any other text editor, you
will notice that it is text file format, and the request and response is stored in comma text format. By default, Sandcat only
logs suspicious responses, test errors or tests that returned positive for the presence of vulnerabilities.

To enable the full request/response logging feature, see Options > Logging. The full log will be available in the Logs folder
under the name "Pkt[current date][time].log".

Note: The full log will usually contain a huge amount of data. Additional disk space may be required for this.

Using the Request Viewer

Requests can be reviewed and managed using the Request Viewer tool (see View|Requests).

Note: This will only work if Sandcat is configured to log packets (requests and responses).

Viewing a request

Click the request to open it. Request data will be available on the bottom of the Request Viewer screen.

Editing and resending a request

To edit and resend a specific request, select the request and click the Edit Request option on the main screen.

Deleting a request

To delete a specific request, select the request and click the Delete option.

Deleting all requests

If you want to delete all requests, select Tools|Clear Request Data. 

Tips
Backing Up the Configuration

Sandcat does not store any important data in the Windows registry. All the important data is stored in the Sandcat folder
(in the Config subfolder), unless custom folders are configured. In order to backup the Sandcat data you just need to
create a copy of the Sandcat folder.

Note: The Sandcat setup creates a file called "Trstapp.inf" in the Windows folder. This file contains the path were Sandcat
was installed.

Better Performance on Old Machines

Intense processing is required during some tests, specially if multithread is enabled (it is enabled by default).

If you disable multithread, CPU usage will be less intense (you can do this by clicking Options in the toolbar and
unchecking the Enable multithread option). 

Choosing the Scan Method

Because the Complete Scan method can sometimes be extensive and a bit time consuming, most users prefer to split up
the assessment by using different scan methods - Common Web Server Scan and then Web Application Scan.

The Common Web Server Scan equals to the first part of the Complete Scan Method, which will look for common
vulnerabilities (no crawling performed) in a very similar way to CGI scanners. The Web Application Scan equals to the
second part, which crawls the web site and performs attacks against the web site structure and the web applications.

If you only want to scan your web applications for common web application vulnerabilities you can choose a third option,
the Fault Injection scan method. This scan method equals to the second part of the Web Application Scan method.

There are two ways to speed up the Web Application Scan (or the Fault Injection scan method):

- Limiting the crawling depth/providing a list of folders and extensions to ignore (this can be done in Options -> Filters).

- Saving the link list of your scan (after it has ended) and then importing the link list as Start URLs in the next scan (this
can be done in the Target Settings screen, Sandcat will remember the settings after this).

Evading Security Mechanisms

If you want to attempt to avoid IDS detection and application firewalls, you can try the following configuration:

Keep the "Enable IDS Evasion" option checked - Our IDS evasion feature is the most advanced and compreehensive.
Some IDS software, however, have evolved to avoid anti-IDS techniques.

Disable DoS Tests - Denial-of-Service tests will always generate many IDS warnings. Disable it.

Enable the "Eliminate PUT/POST/DELETE requests" option - These types of requests may also generate many IDS
warnings.

Enable the slowdown option - This will make the scanner wait a few milliseconds before starting each check. You may
also want to specify the slowdown time - see the Slowdown (ms) option.

Minimizing False Positives

There are many ways to minimize false positives in Sandcat. It is possible to configure custom error page detection
signatures (global or host-specific) and create custom signatures to validate findings of specific web application security
checks.

Note: Please be careful while making some changes to the product, such as creating user signatures for detecting
application vulnerabilities. Sandcat already contains signatures for detecting these vulnerabilities. If the quality of your
signatures are bad, the detection accuracy may decrease, and then false positives or negatives can happen. It is better
(and safe) to rely on its default signatures.

Sandcat is a highly customizable software, you should not have any problems customizing your scans. If you miss some
feature, drop us an email. Many customization features that are available today were derived from customer suggestions.

Error Page Signatures

Sandcat Signatures apply to both the web application scan and the web server scan modules. If you use the
Advanced/Error Pages menu option to add/remove error page detection signatures, it will be a global setting (that applies
to all hosts).

If you add a signature using the Request Viewer, it will be host specific, not a global setting that applies to all hosts. The
target settings screen of the Sandcat GUI also allows you to see and edit these host specific signatures. You can also
edit the same signatures via the Tools menu in the Request Viewer utility. 

Request Timeout Errors

Sandcat may sometimes show a notification of timeout during a scan. Timeout errors relates to the time the webserver
takes to respond. Don't worry if there is a small number of timeouts. Sandcat was developed to retry* these requests. But
when this happens too many times, you should:

1) Check what is the timeout config that is currently being used - You can try doubling or trippling the timeout value in ms
in the Options screen.

2) Consider decreasing the number of threads

3) Consider disabling the multithread feature - all packets will be sequential, and then you can check if the timeout error
still occur.

(*) The latest Sandcat versions will automatically retry the request if there is a timeout (unless you change the number of
retries to 0). 

Speeding Up Sandcat

Here is how to make Sandcat even more fast.

In Options -> General:

    * Keep Enable multithread checked
    * Additionally, try increasing the Maximum number of threads.

In Options -> Scan Settings:

    * Keep the reconnaissance, fast CGI scanning and maximum optimization options enabled

    * Keep triple checking disabled - Specially if the target server is not case-sensitive

In Options -> Filters:

    * Limit the crawling depth (if possible)
    * Provide a list of folders and extensions to ignore

In Options -> IDS Evasion:

    * Keep IDS Evasion disabled

In Options -> Logging:

    * Keep the "Log all packets" option disabled

In the Target Settings screen:

    * Import the link list of your last scan as Start URLs

FAQs
Basic FAQs

How many time Sandcat will take to run all the tests?
Duration depends on the number of pages and applications your website contains and the scan method you selected. The
web application checks (crawling stage) is usually the part of the scan that can take more time and depends on the size of
the target site.

Can I increase the number of threads?
Yes, you can. Sandcat was coded to detect and inform about performance problems during the scan. Just keep an eye in
the Events screen. If you see a large number of timeouts then your system (or the target system) is not handling it well.
Don't worry if there is a small number of timeouts. Sandcat was coded to retry these requests.

Can I load a previous scan session and re-run reports again?
Yes, this is possible since the 3.0 release. Select the View option from the menubar and then Sessions. The Session
Manager screen will open. Double click the name of the previous session you want and you will see the session results
and the options to export data and generate reports.

How Sandcat comes up with it's rankings (high, medium, low, etc)?
The Sandcat rankings are based on vulnerability categories and sometimes on individual vulnerabilities and sometimes on
the server's response to specific requests. Currently you can also easily group these vulnerabilities by generating a
compliance report (just choose the compliance option when saving a report).

Is there a list of tests that are conducted using the updated version of Sandcat?
You can get an idea of the tests by clicking the menu About, and then select "Vulnerability List". See 
http://www.syhunt.com/section.php?id=updates for the last update. This page gives you some idea of what gets added to
Sandcat every month.

Are these tests CVE compliant?
Not all the checks have CVE numbers, but anything with a CVE is included in the scanner. So, any exploit that has been
posted to forums like Bugtraq is in there as well, in addition to variations on exploits. For example, Sandcat checks for
several hundred forms of the Unicode exploit. There are also filters to prevent false-positives on all these checks.

Do any of the tests crash the tested host?
As far as crashing the host - there are denial of service checks which may crash the tested host - you can turn those off
when scanning though.

Is there any way to provide a list of IP addresses (not necessarily in the same range) for scanning?
Yes. See Basic QuickStart for detailed information on this.

How can I configure the DB Update?
You should enter these in the Login screen:

   1. Start Sandcat
   2. Click the menu File-> Login option
   3. Fill in your username and password. Note that they are case sensitive. And press Connect.

When was Sandcat's last database update?
See http://www.syhunt.com/index.php?section=resources.updates for the last update.

Does Sandcat have any problems with personal firewalls?
Yes, you'll just have to let the firewall know that Sandcat is authorized to make connections to the Internet. However,
some software firewalls do not handle high loads very well. It is not recommended to run both a personal firewall and
Sandcat on the same machine.

If you're running a PC firewall on the scanning system that does outbound filtering, try disabling it - we've occassionally
seen firewalls automatically block a program's socket calls without first prompting the user as to whether or not it should
be allowed to make connections.

Is there any way to scan ports 23 (telnet) and 21 (ftp)?

Sandcat is not a general purpose security scanner, it is specialized for evaluating web servers. The port option is just there
for HTTP servers that happen to run on something other than 80.

Is there any way to use a proxy server for web scanning?
Does your net connection require a proxy server for web access? If so, you'd have to configure Sandcat with that
information. Sandcat will ask for this information after the installation. Using proxy servers for HTTP scanning is also
possible, but not recommended.

I am testing a system that has webservers running on ports other then 80. How do I scan those webservers with
Sandcat? 
There is a ports field you can use. It is located in a toolbar on the right side of the Sandcat GUI. You can replace the
default port value with the port value you need or you can specify more than one ports separated by commas.

Injection & Spidering

Q: What inputs it checks and how it determines if it has found SQL injection or cross-site scripting?

A: Everything starts with the index page of the target website, some additional specific remote files (such as robots.txt)
that may be available, and URLs specified as Start URLs by the user (this one optional).

Sandcat will then map the entire site structure until reaching the maximum depth limit, which means all the web site
pages. During the html parsing, it will extract and compile information about all the web site links, forms, folders,
applications, etc, everything that can be analyzed and targeted. Parts of these web pages are instantaneously analyzed
(for dangerous comments, email form hijacking, unencrypted login and such), while other parts, like fault injection checks,
are left for the end. They take place after the spidering stage.

During the fault injection stage, Sandcat then targets all the forms and URLs. Form and URL parameters are manipulated
in many different ways and sequences in the entire website. It will fill in forms using common form inputs (eg, if it asks for
city information, it will use New York). After the submission is completed, Sandcat analyzes the web server's response
and checks if there is any sign of success.

Q: In reference to the Wikipedia article on XSS, what types of XSS attacks are detected by Sandcat?

A: Types 1 and 2 described in the Wikipedia article are extensively covered. Type 1 is actually what we refer as "URL
manipulation" in our documentation. Type 2 is what we refer as "form field manipulation". Type-0 attack is not covered
because it is not specifically a server or web application flaw.

Name Changes

What happened to Sandcat Platinum and TrustSight?
Sandcat Platinum was renamed to Sandcat Pro (or Professional) a few years ago. The TrustSight technology was
absorbed into the Sandcat software.

What happened to Collapse?
Collapse is now the main GUI application of Sandcat. It integrates all the functionality of Sandcat. It is still possible,
however, to start the Sandcat Scanner and Miner modules as individual applications (via the Tools menu).

FAQs for New Users

Q: I´m interested in tests such as SQL injection, cross site scripting etc. Does Syhunt perform such tests?

A: Yes, Sandcat does extensively perform these tests and lots of other fault injection tests. Please, check out
http://www.syhunt.com/index.php?section=sandcat.checks for more detailed info.

Q: If there is a code change to the web application, then will the Syhunt tool natively detect the vulnerability or
does Syhunt also have to upgrade the scanning tool?

A: The Syhunt's web application scanner is able to test custom-built web applications. This means that if a code is
changed and the application becomes vulnerable from one moment to the next to some common type of attack (XSS, SQL
Injection, and other web attacks), the web application scanner will be able to detect and report the issue.

Q: The web site says Sandcat is free. Is this correct?

A: Sandcat is available in two editions - free and professional. The free edition does not include automatic updates,
reporting features, add-ons and other critical features.

Q: What is the difference between the free copy and the Pro Edition?

A: Please visit http://www.syhunt.com/index.php?section=sandcatpro.pricing for detailed info on this.

Q: Whether the Sandcat product looked at all webpages on my host, as by default, there are no links on the
main site?

A: Sandcat will not only map and test applications for web application flaws. It will also try to locate common files and
folders, database files, common vulnerable scripts, backup files, common backup folders and files in the root folder and all
referenced subdirectories (if there are no subdirs, then it will be restricted to the web server root). These files and folders,
that Sandcat will also try to expose and analyze, are not necessarily linked in any way to any web content.

Sandcat and Web Application Security

1. How easy is Sandcat to use? Can the average network administrator really identify problems with their web
servers and applications?
Sandcat is a highly customizable solution and can adapt to almost any scenario. It has a clean and simple GUI. The
default settings are usually adequate, but can also be adjusted for each target. The session information compiled and
stored during a scan can be used to review data, re-send requests, generate pass/fail reports, and also can be exported to
multiple file formats.

2. How does Sandcat prevent false positives?
Multiple methods are used to prevent false positives, such as analyzing the server's response for signs of the vulnerability
being tested for. We advised users to be careful while making some changes to the product, such as creating user
signatures for detecting application vulnerabilities. Sandcat already contains signatures for detecting these vulnerabilities. If
the quality of the user's signatures are bad, the detection accuracy may decrease, and then false positives or negatives
can happen. It is better to leave this to the experts and rely on its default signatures. If you're a security expert, okay, then
go on and Sandcat may yield even better results after some sophisticated fine tuning.

3. How is Sandcat likely to change in the coming releases? Do you have plans to support AJAX and other
emerging application technologies?
We've been expanding the Sandcat scanning features according to the emerging technologies. We know that
organizations are going to have even more complex websites with the adoption of technologies such as AJAX, and we have
to be prepared to help these organizations secure their sites. Sandcat 3.0 is already able to exploit AJAX-based web
applications. Emerging application technologies, all will be supported.

4. Besides scanning, what other things should network admins be doing to secure their environment? Can
Sandcat help them with these tasks?
Sandcat includes a web server hardening tool. While performing, for example, an OWASP PHP Top 5 scan, Sandcat will
cover items P1 (remote code execution), P2 (cross-site scripting), P3 (SQL Injection) and P5 (file system attacks) and it
would be necessary to manually check the PHP configuration to check compliance with the P4 item (PHP configuration) of
the OWASP PHP Top 5 guideline. The PHP configuration cannot be properly analyzed from the network. This can only be
done locally, by having access to the configuration file. Once you have access to the PHP configuration, the Sandcat
Hardener can automate the configuration analysis. The tool will evaluate the security threats and identify appropriate
countermeasures. This is one of the software's unique features. Sandcat is the first web application scanner that can
address all the OWASP PHP Top 5 guideline items.

5. What are attackers looking for in victim systems? How are they attacking applications today? What do you
think will be the source for new attacks in the future?
Right now we're concerned about known and unknown PHP and ASP vulnerabilities. Every day numerous vulnerabilities
are being discovered in various web systems and new entries are created for these vulnerabilities in databases worldwide.
Web applications are becoming more and more complex and hackers are taking advantage of it to exploit systems.

6. What about web server worms? It has been a long time since NIMDA and Code Red. Will we see future
web-based worms as dangerous as those were, or are they a thing of the past?
Traditional viruses are thing of the past, dangerous worms not. The first AJAX worms have already been developed. At least

organizations are more prepared than they were in 2001 to defeat worms.

7. How does Sandcat protect against threats like SQL Injection, Cross Site Scripting and Buffer Overflows? Can
the tool be used to help Quality Assurance teams make sure web applications are safe before they go into
production?
To detect these vulnerabilities, Sandcat relies on numerous URL/form parameter manipulation techniques. Sandcat is also
able to find known vulnerable scripts in the web server's tree, even if they are not linked anywhere, and then exploit these
scripts. This is a more advanced approach.

A special attention has been given to the the SANS Top Twenty, the OWASP's Top 10 and PHP Top 5 guidelines.
Sandcat 3 is able to generate compliance reports, listing all of the web servers that do not comply with these main
guidelines and standards, and specifying details and recommendations.

Updates
Updating Sandcat -- Members Only

Sandcat includes a SmartUpdate tool, this tool automates the engine and database updates. You can retrieve the latest
version and updates using this utility (just select menu Tools, SmartUpdate, and it will download and install the latest
updates).

Or you can manually download and install the updates at http://www.syhunt.com/index.php?section=members.home.

If the automatic update feature is enabled*, you will see notifications about updates in the Sandcat GUI. Click "Install" and
Sandcat will download and install the new components.

(*) In the newest versions of Sandcat the update checking is performed by a Sandcat extension called Update Checker.
This extension is enabled by default. In order to execute both the Update Checker and the SmartUpdate application you
need Internet access, more specifically HTTP protocol. 

Note: Syhunt offers regular monthly/weekly updates, and immediate updates, depending on the risk associated with the
new vulnerabilities. The free edition doesn't give you access to the latest product updates. You may lose in performance
and ignore important security checks that are only available in the latest components and databases.

Release Notes

Version 3.5

NEW INTERFACE

    * New themeable and extensible GUI, which is built using new standards.

    * Menu Tools/Themes displays all available themes and allows to switch between themes.

    * Menu Tools/Extensions displays all available extensions and allows to configure them.

    * Sandcat will now automatically remember the last toolbar position.

    * New redesigned configuration screen (for Options & Checks). The new Checks screen allows to enable or disable
multiple checks with a single click.

    * Many thanks to Paul Woroshow for pointing us into this direction.

SETTINGS STORAGE CHANGES

    * Sandcat (and its modules) now stores all settings in the Config subfolder. For this reason, your settings (from the
previous version) will not be detected by Sandcat. To import your previous settings, use the Load Settings option in the
File menu. Settings from the previous release will be located in the Plc subfolder (in the General.cfg file).

    * The Target Settings specifically are now stored using a different format. Previous settings (using the old format) will not
be detected and have to be re-entered in the Target Settings screen. If you have created settings for a big number of hosts,
and this is a problem, please contact us and we will provide you with a conversion utility.

EXECUTABLE NAME CHANGES

    * For those running the Sandcat modules individually from the command line, it is now necessary to use different
executable names. If you've created any shortcuts, you also have to update them. You can find the new executable names
below.

    Sandcat Server Scanner - Renamed to Srvcheck.exe
    Sandcat Log Analyzer - Renamed to Logcheck.exe
    Sandcat App. Scanner - Renamed to Secrobot.exe (previously known as Miner)

SANDCAT EXTENSIONS AND THEME SUPPORT

    * Extensions and Themes are available via compressed packages with extensions .scx (SandCat EXtension) and .thm,
which should be copied to the Apps or Themes subfolder respectively.

    * Sandcat Extensions can be written in Python or Pascal. Before running Sandcat it is recommended to install Python
2.5 (or the latest available version) or these extensions will not be available. The Update Checker extension, for eg, has
been written in Python language and will not work if a Python installation is not found.

    * We plan to enhance the extensions support, add new extensions on a regular basis and also create a site for
user-made extensions in the near future.

CREATING NEW EXTENSIONS AND THEMES

    * It is very easy to create new extensions, integrate them to the GUI and even create a configuration screen for these
extensions. You just need some knowledge of HTML/CSS and Python or Pascal programming language. GUI screen
replacements can also be created. More details will be available separately.

OTHER ENHANCEMENTS AND CHANGES

    * Improved multithread functionality.

    * Packet files are now automatically saved in the Logs/[Session Name]/ subfolder.

    * Custom log format files must now be placed in the Config/Logfmt subfolder.

    * Custom templates should be placed in the Config/Templates subfolder.

    * Custom File Checks - Customfc.inf file has no use anymore. Please use Config/Customfc.lst instead.

    * Have you created any custom server checks? They must be placed in the Exploits subfolder. The Db subfolder has no
use anymore.

    * Custom exploits using script format are not supported anymore. We plan to develop a similar, but enhanced and
simplified feature in the future.

    * Smaller setup.

CLEAN UP

There are numerous files and folders that have no use anymore with the new version. Run Cleanup.bat (located in the root
of the Sandcat installation) to remove them.

BUG FIXES

    * Fixed display of scan progress during the end of the Application Checks stage.

    * Fixed a single timeout occurring during the execution of the Outdated Server Software Test.

    * Fixed an exception error occurring sometimes after the execution of the Recon stage.

    * Fixed timeouts occurring sometimes during the scans. This was often not an issue because of the check retry feature.

    * Fixed a protocol modification that was causing 100% CPU usage during scans in the 3.4 version.

    * Fixed a typo in the Log Analyzer screen. Many thanks to Glenn Blair for reporting this.

Version 3.4.0.3

    * Added new server checks.

    * Updated documentation.

Version 3.4.0.2

    * Minor improvements.

Version 3.4.0.1

    * Minor improvements.

Version 3.4

    * Enhanced support for large websites.

    * Improved speed.

    * Fixed a few false positives.

    * Minor fixes and improvements.

Version 3.3.2

    * Enhanced support for different environments.

    * Enhanced email collection.

    * Vulnerability details screen now allows to edit vulnerability description and recommendations. Vulnerability details can
also be edited using the Report Editor utility.

    * Notifications related to the Maximum URL length restriction now contain the exact URL ignored.

    * Improved GUI performance.

    * Fixed bug related to certificate filenames.

    * Fixed small bug in displaying vulnerability information for a few specific web app sec checks in the main Sandcat or
Report Editor screen.

Version 3.3.1

    * Improved speed.

    * Improved timeout handling. Timeout verification is now restricted to requests.

Version 3.3

    * Added Resume Feature -- Ability to stop and later resume a scan session. It works for all scan methods and target
options. A past session can be loaded from the main screen or via the File menu ("Load session" option).

    * Added ability to configure a maximum cookie size and the maximum number of cookies per server. (See Options ->
General)

    * Improved memory usage and long-term stability (specially when dealing with a large list of targets)

    * Report graphics are now automatically regenerated after edits. If you are using a custom template based on the
original Sandcat HTML or PDF report template, you will need to update it. Detailed instructions are available below.

    * Vulnerability details screen can now display user modifications.

    * Additional optimizations were made to speed up scans.

    * GUI Preferences is now available as a subitem in Options panel.

    * Minor fixes and improvements.

FIXING YOUR CUSTOM HTML/PDF REPORT TEMPLATES

    * This is only necessary if you have created any custom HTML/PDF report templates.

    * Find and replace the following texts:

    Find: <$value:pie chart 1$>
    Replace with: <$report_session$>\<$value:host$>_1.jpg

    Find: <$value:pie chart 2$>
    Replace with: <$report_session$>\<$value:host$>_2.jpg

    Find: name="pie chart 1"
    Replace with: name="host"

Version 3.2

    * Added new server checks.

    * Enhanced HTML Parsing.

    * Improved web form login detection.

    * Improved cookie handling.

    * Improved speed.

    * Minor improvements.

Version 3.1

    * Added new server checks.

    * Major database optimizations.

    * Added some more intelligence to report application security vulnerabilities.

    * Additional vulnerability details to reports (Recommendations and Affected Params for vulnerable applications).

    * Added ability to customize CGI dirs for the web server scan. This is available under Checks/Server Checks in the main
Sandcat Interface.

    * Improved speed.

    * Faster SmartUpdate.

    * Smaller setup.

    * Fixed small bug in displaying vulnerability description and recommendations for a few specific vulnerabilities in the
main Sandcat screen.

Version 3.09

    * New, improved manual.

Version 3.08

    * Added Time Left information in the Events screen.
    * Minor improvements.

Version 3.07

    * Added new server checks.
    * Denial-of-Service engine rewritten.
    * Added retry notification in the Sandcat Scanner tool.
    * Fixed minor bugs.

Version 3.06

    * Added new server checks.
    * Added option to export data in StickWiki page format.
    * Minor GUI changes.

Version 3.05

    * Added new server checks.

Version 3.04

    * Added new server checks.
    * Added CWE (Common Weakness Enumeration) support.
    * Added option to clear the StartURL list.
    * Log Analyzer executable renamed to "Logatool.exe".
    * Fixed rare issue while switching target type.
    * Fixed small issue in the Apache/PHP Hardener add-on.

Version 3.03

    * Added MX Injection checks.
    * Improved signatures.
    * Improved Install application.
    * Fixed minor bugs from 3.024 version.
    * Minor GUI changes and improvements.

Version 3.024

    * Added an option to send results by email from the session results screen.
    * Improved Uninstall application.
    * Minor GUI changes and improvements.

Version 3.023

    * Added option to export data in XLS (Excel) format.
    * Improved PDF export.
    * Additional optimizations were made to speed up report generation.
    * Fixed minor bugs.
    * Minor GUI changes and improvements.

Version 3.022

    * Improved PDF export.

Version 3.021

    * Fixed minor bugs in generating PDF reports.

Version 3.02

    * A new add-on has been developed for configuring target settings.
    * Minor GUI changes and improvements.

Version 3.016

    * Major optimizations to speed up report generation.

Version 3.01

    * Sandcat is now able to exploit AJAX-based web applications.
    * Added an option to pause the scan if there is an excessive number of timeouts (see Options -> General -> Timeout
from the standards buttons toolbar). Sandcat will warn if there is excessive timeouts, show recommendations and pause
the scan if the option is enabled.
    * Added ability to enter host specific error page signatures. If you add a signature using the Request Viewer, it will now
be host specific, not a global setting that applies to all hosts. We've also added a tab in the Target Settings screen of the
Sandcat GUI that allows to see and edit these host specific signatures.
    * It is still possible to use the Advanced/Error Pages menu option to add/remove error page detection signatures, but
this

list will be a global setting (that applies to all websites).

    * Improved timeout and error handling.
    * Fixed log analyzer add-on.
    * Fixed minor interface problems with the Request Viewer.

Version 3.0

SESSION MANAGER

    * All new assessments will now have a specific name (session name). An add-on has been developed for managing
sessions.
    * Sandcat will prompt for a session name when an assessment starts.
    * There's an option that tells the scanner to never prompt for a session name (see Options -> General -> GUI
Preferences from the standard buttons toolbar). If this option is enabled, Sandcat will automatically choose a session
name based on the current date and time.
    * Sandcat instances can now have different settings. It is also possible to load settings from an external file or past
session, and to load the application's default settings (see File -> Settings from the menubar).
    * Default scan method changed to Complete (No DoS).
    * Added option to configure the default scan method (See Options -> Scan Settings from the menubar).
    * Added new, redesigned screens for managing options and checks.

REPORT DESIGN

    * It is now possible to edit report information, such as description, solution, and other info, before generating it. The

Session Results screen also allows to include/exclude certain results and parts of the report and to edit user notes for
each report item.

    * Multiple report templates are now available, such as Standard, Complete and pass/fail reports. SANS Top 20,
OWASP PHP Top 5 and OWASP Top 20 compliance report options were added.
    * Sandcat now generates reports in HTML, PDF, XML, Text, RTF and DOC format. It is possible to edit the template for
all the available report methods, and to use custom templates.
    * Sandcat now exports data in CSV, Text, XML, INI and List file format. It is possible to export emails, HTML
comments, HTML forms, hidden form fields, links and other information.
    * Added option to insert a company logo (URL or file) in the report (see Report -> Settings -> General Options from the

standard buttons toolbar).

    * It is now possible to generate reports while the assessment is still being executed.
    * Added an option to filter results.
    * Command line support is available with the report generator (See the "Cmdline.txt" file for detailed information).
    * Most options related to the inclusion/exclusion of certain parts of the report were moved to the report generation
screen.
    * Removed "Store scan results and reports as XML files" option. This option has been replaced by the report generation
screen.

LOGGING

    * Added options to log suspicious responses and test errors for review (see Options -> Logging from the standard
buttons

toolbar). These new options are enabled by default.

    * Suspicious responses can be reviewed using the Request Viewer tool. During the review process, a suspicious
response

can be marked as a positive and then added as a new vulnerability to the report.

    * Logged packets are now associated with the current session ID.

APPLICATION CHECKS

    * Added new application checks: Email Form Hijacking, Hidden Price Form Field, and Unencrypted Login. These
checks can be

turned off if required (see Checks -> Application Checks from the standard buttons toolbar).

    * Added option to enter a start URL as target (see Target from the scan bar).
    * It is also possible to enter multiple Start URLs or to load a link list from an external file (see Target Settings from the
scan bar).
    * Added option to enter form authentication info. Sandcat will automatically detect login forms and use the login info to

log in (see Target Settings from the scan bar). Username and password fields, and additional form values can be
configured
(see Advanced -> Form Inputs from the menubar).

    * Added options to analyze robots.txt file and javascript (see Advanced -> Crawling Depth from the menubar).
    * Added "Distribute requests randomly" option (see Options -> Advanced Options from the standard buttons toolbar).
This option applies to the crawling process. If enabled, Sandcat will visit the found URLs in random order rather than
hierarchical order.
    * Added multithread functionality into the application scanner

module.

    * Sandcat can now retry a request if it fails (see Options -> Advanced Options from the standard buttons toolbar). The
default number of retries is 2.
    * Sandcat will now show the list of links found during an assessment. It is possible to export this list using the Session

Results screen and use the list as start URLs in the next assessment.
    * Improved application checks: Comments in HTML.
    * Improved speed and stability.
    * Improved parsing.

DEPTH, FILTERS AND SIGNATURES

    * Added new options to edit the crawling depth: Maximum number of links per server, maximum links per page,
maximum URL length and maximum response size.
    * Added options to create user signatures for detecting application vulnerabilities (see Checks -> Application Checks ->

User Signatures from the standards button toolbar).

    * Added options to prevent logout and to relogin when needed (see Advanced -> Logout Pages from the menubar).
Logout pages

can be entered and signatures can be configured to check if a logout occurred.

    * Added option to search for suspicious strings in HTML comments. It is possible to enter a list of suspicious strings.

(see Advanced -> HTML Comments from the menubar).

    * Added option to enter a list of common form values (see Advanced -> Form Inputs from the menubar). Some internal
variables are available.
    * Added option to ignore common unnecessary URL/form parameters. Additional objects can now be specified to be
ignored during the testing process, such as a list of URL/form parameters, certain pages, folders or extensions (see
Advanced -> Ignore List from the menubar).
    * User error page detection signatures moved to Advanced -> Error Pages. It is now possible to specify regular
expressions.
    * Old signatures - It is necessary to re-enter error page signatures in this version. The old signatures will not be loaded.
You can manually import the old filters from the "Fpfilter" file in the root of the installation path of Sandcat.
    * Improved error page signatures.

SERVER CHECKS

    * Improved server checks: Denial-of-Service, Outdated Server Software.
    * Dramatically improved speed.
    * Improved stability.

OTHER CHANGES AND IMPROVEMENTS

    * Added option to enter custom header fields (see Options -> Scan Settings -> Misc Options from the standard buttons
toolbar).
    * Sandcat can now dynamically adjust the number of threads (see Options -> General from the standard buttons
toolbar). This option is enabled by default.
    * Added more information about scan methods.
    * Main executable renamed to "Sandcat.exe". It may be necessary to update your Windows shortcuts.
    * Improved automatic update feature. SmartUpdate will ask before closing any active modules.
    * Improved timeout and error handling.
    * Improved cookie handling.
    * Improved proxy support.
    * Improved HTTP-SSL support.
    * Improved GUI performance.

Updating the License Information

Your license info should be entered at the login screen (menu File/Log in option). Clicking "Connect" will save/update the
config.

If you need to change the registrant's name and company, please email register@syhunt.com

You can also provide additional emails to receive the Sandcat newsletter.

Support
Reporting Issues

Did you find an anomaly? Please notify us at bug@syhunt.com.

The following information may be useful to accelerate the review:

   1. What is the target server software (name and version)?
   2. What is your OS (name, version and edition) and hardware details?
   3. Did you experience this issue with other target servers?
   4. Screenshots and log (usually the latest log file in the Logs folder (name format is [date][time].log))
   5. Configuration files (all configuration files are located in the Config subfolder).
   6. Version number of the files Sandcat.exe, Srvcheck.exe and Secrobot.exe

Requesting Features

Do you have any thoughts on improving Sandcat?

What is your opinion about the recent product improvements?

We've been updating Sandcat on a regular basis with new features and improvements, and user comments are a main part
of the evolving process. Your feedback and suggestions are very welcome. You can always send us feature requests and
contact our tech staff directly at sandcatdev@syhunt.com
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